Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Cannot Enter Security Key on Launcher, so Cannot Launch Game

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Cannot Enter Security Key on Launcher, so Cannot Launch Game

Soobe's Avatar

10.02.2012 , 10:46 AM | #1
As of this morning, I cannot enter my Security Key on the launcher, so I cannot even patch the game or get into the launcher to run a repair to see if that would correct whatever the freakin' problem is all of a sudden (it worked fine night before last, so I presume it's a problem with this patch?), nor can I play the game.

Tried calling customer support at 1-855-467-9867 only to be told "our systems are down, call back later. We don't know when they'll be up, so just keep trying."

No, I do not want to remove my security keys from either of my accounts. Not only does it kind of defeat the purpose of having the darn things to begin with, but I have characters who are wearing items from the security key vendor (and I don't really want to see characters in their skivvies, thanks) and other characters who make liberal use of security key vendor items that I'd prefer not to lose because somebody at BioWare screwed up. Yet again.


Just get it working, please. Thank you.
All these people you're playing [MMOs] with? They're real people...with real feelings. What you do in game matters just as much as what you do anywhere else. You don't get to discount any of it because it's "just a game." --Lisa Poisso, WoW Insider