Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Graphics issues post 1.4 - hard locks, stuttering, lag

STAR WARS: The Old Republic > English > Customer Service
Graphics issues post 1.4 - hard locks, stuttering, lag

Thunn's Avatar


Thunn
09.28.2012 , 12:58 PM | #1
Good day, I play on a machine that has dual AMD Radeon 5770's in CrossfireX configuration. I had been using the most recent stable AMD drivers, version 12.8. All was well until patch 1.4. After the patch, usually within just a few seconds of my loading into the game, the entire system locks up hard, requiring a physical reset. The character selection screen still functions, but not the main game.

After reading as much feedback as I could here, the two most pertinent suggestions were to disable shadows, or disable CrossfireX entirely. Neither is a very viable long-term solution, but in the interests of troubleshooting I tried both. The lockups would take a minute or two longer to occur, but occur they did.

Next step was to follow AMD's instructions for a complete removal, then clean reboot before reinstalling the 12.8 drivers. This did not help. I then tried all of the available configuration combinations after rolling back to the version 12.6 drivers; in that situation the game functions, but the stuttering/lag is unbearable, particularly in any maps. Despairing, I did yet another clean uninstall, and tried the beta 12.9 drivers dated 27 Sept. While CrossfireX was still a no-go, I was finally able to get the game to run on one card at low graphics settings, with no shadows. I still encounter minor stuttering and lag delay on some abilities in PVP, but it's bearable (barely).

Essentially at this point, I'm left with a system with crippled graphics and limited performance simply to play SWTOR. Everything was fine right up until the moment of the patch, all has gone to hell since. I've now wasted 4-5 hours of configuring and loading just to get minimum playability. We're on day three with no fix or even official statement from Bioware over these crippling issues. I respectfully request that either a fix be provided immediately, a rollback to previous game engine files, or an official statement detailing steps taken and timeline to completion. Continuing to charge me for a broken product in this state is not acceptable, Bioware will lose my business if these issues persist beyond next Tuesday's maintenance time.

Thank you for your attention and prompt reply.

Thunn's Avatar


Thunn
09.29.2012 , 11:11 AM | #2
A day and a hundred views later with no response is not what I'd consider a prompt reply.

SkuzBukit's Avatar


SkuzBukit
09.29.2012 , 11:13 AM | #3
I found 12.8 terribly unstable on my rig, ended up going back to 12.4 (12.6 were unstable for me too).

But since 1.4 I've seen a return of the "crash on exiting game" bug that completely hard-locks my PC, meaning it hasn't saved my preferences & each time I boot up I have to go back into preferences to set them up again all over, very annoying.
Mercenary 55 | Assassin 50 | Marauder 50 | Sniper 50 | Operative 55 | Sorcerer 55 | Powertech 51 | Juggernaut 55
Gunslinger 55 | Guardian 55 | Sage 55 | Vanguard 55 | Scoundrel 27 | Commando 22 | Sentinel 22 | Shadow 21

InfinityInfinity's Avatar


InfinityInfinity
09.29.2012 , 11:14 AM | #4
Try disabling nameplate scaling. This worked for me. I still get the crazy minimap display, but no more huge lag spikes. I also have shadows disabled.

Thunn's Avatar


Thunn
09.29.2012 , 11:34 AM | #5
Quote: Originally Posted by InfinityInfinity View Post
Try disabling nameplate scaling. This worked for me. I still get the crazy minimap display, but no more huge lag spikes. I also have shadows disabled.
Saw your post and tried that, thanks Infinity. Unfortunately it didn't really help much; the game was still in such a state that I couldn't play it. So far, only crippling my video cards seems to make things barely playable.

InfinityInfinity's Avatar


InfinityInfinity
09.29.2012 , 11:36 AM | #6
sry to hear that...was hoping I stumbled onto something...Hopefully they release a fix soon.

Thunn's Avatar


Thunn
09.29.2012 , 12:31 PM | #7
At the suggestion of another poster I changed my graphics settings from "full screen" to "full screen (windowed)" mode. Thus far, things are working vastly better.

Thunn's Avatar


Thunn
09.30.2012 , 06:53 PM | #8
After a day of use, I can say with some authority that "full screen (windowed)" mode has corrected my issues.