Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

1.4 Broke CrossFire

First BioWare Post First BioWare Post

Omophorus's Avatar


Omophorus
09.26.2012 , 03:15 PM | #41
Quote: Originally Posted by Gawlron View Post
I set my SWTOR Profile in NVCPL to Single-GPU rendering... my FPS is locked at 60FPS (flux'ing 2-3 frames), but the stuttering is still pretty bad.

EDIT: Moved to Fullscreen (Windowed) > problem no longer exists, turning on SLI to see what happens.

EDIT2: Turning the SLI on caused my frames to drop from steady ~60FPS to 30-40FPS + staggering.

I hope this information helps Devs out.
I doubt you're seeing actual SLI behavior with fullscreen windowed.

Multi-GPU setups + windowed games rarely ever work properly and provide really inconsistent results even if they do.

So far as I know there is a tiny handful of games where SLI functions semi-normally windowed, and a grand total of 0 for CrossFire due to obscure, arcane architecture/driver design reasons.

KPureblade's Avatar


KPureblade
09.26.2012 , 04:48 PM | #42
Reporting in, Crossfire setup and have terrible framerate issues and flickering minimap. Turning shadows to OFF did not help.

DXDiag info:
Spoiler


Going to try disabling crossfire next, will report back.

UPDATE: Disabled Crossfire, runs much better now, but would like to see this fixed as soon as feasible. Thanks!

KPureblade's Avatar


KPureblade
09.26.2012 , 04:54 PM | #43
And a note to others: As Omophorus mentioned above, changing games to Windowed mode is the same as turning off Crossfire/SLI in most cases. Fullscreen (Windowed) also counts.

DarthSithdious's Avatar


DarthSithdious
09.26.2012 , 06:51 PM | #44
Quote: Originally Posted by KPureblade View Post
And a note to others: As Omophorus mentioned above, changing games to Windowed mode is the same as turning off Crossfire/SLI in most cases. Fullscreen (Windowed) also counts.
experiencing it, since i own the system is different....at least for me, when the game runs in full screen, it is stuttering and wacky frame rate. when it is on fullscreen windowed, no stuttering and frame rate is 40-60, just as it was pre 1.4 with fullscreen. So, i don't know what is going on, but something is screwy.

Sushyy's Avatar


Sushyy
09.26.2012 , 06:59 PM | #45
for those with crossfire stating the game runs better in fullscreen (windowed), crossfire is not supported in fullscreen (windowed mode) so you're basically disabling crossfire and thus the game is becoming playable again. Disabling crossfire via control catalyst and playing in regular full screen mode would yield the same results. While this is a temporary solution, I should not have to disable crossfire in order to make the game playable.

Zentelis's Avatar


Zentelis
09.26.2012 , 07:07 PM | #46
I was unable to get into the game because the character selection screen was solid pink. Radeon 4870x2 here with the driver version 8.970.100.3000.
I modified the client setting file and set D3DFullScreen = false. I was able to get into the game, then and am currently playing it in windowed mode.
I had tried disabling crossfire through CCC, but it didn't seem to work.

Thanks for the tip about windows mode..I hadn't thought of that.

Though I do agree..we shouldn't have to disable crossfire just to play a game..especially when crossfire worked before the patch.

Hansojojo's Avatar


Hansojojo
09.26.2012 , 07:41 PM | #47
Swtor has to fix update 1.4 cause its not letting me download it.And I see other people have problems with it to swtor plz plz plz fix this

paowee's Avatar


paowee
09.26.2012 , 10:46 PM | #48
broke more than just crossfire. a bunch of people not using crossfire are experiencing the same problems.

i used to be 60 fps now im at 8fps during a boss fight. was ok before 1.4.

radeon 6700
Republic < Intrepid > The Harbinger slinger sage vanguard dps
swtorboard.org dps blog.class guides.end-game stuff
16 man | 8 man DPS leaderboards | Galactic Starfighter Records

Boozek's Avatar


Boozek
09.27.2012 , 04:51 AM | #49
Could we possibly get a yellow post or be consolidated with another post where you have given relevant information about this issue? (I know that there are about 50 video lag threads at this point, but this is the most relevant one tbh because the problem has been identified and people like myself having a single graphics card with a dual gpu have no way of disabling crossfire)

I know you are busy but the issue was known on the PTR but you insisted on going live bugs and all.

Boozek's Avatar


Boozek
09.27.2012 , 05:27 AM | #50
Spoiler
This post has been edited to include spoiler tags – CS Forum Team