Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Developer Update: Shadow Optimizations in Game Update 1.4

STAR WARS: The Old Republic > English > General Discussion
Developer Update: Shadow Optimizations in Game Update 1.4
First BioWare Post First BioWare Post

Glzmo's Avatar


Glzmo
09.26.2012 , 01:47 PM | #101
I'm having horrible performance in Game Update 1.4 with 2x Nvidia GeForce GTX 580 3GB SLi. Turning off shadows helps with performance a little, but the performance hit compared to 1.3 is there even with shadows disabled, and if you monitor GPU utilization, you will see that SLI isn't actually working properly (same with CrossfireX, by the way).

The following are some comparisons with Image Quality Preset set to Very High, both with Game Update 1.3 and 1.4:

Example 1: Tython, in front of the Jedi Temple. All three measurements were made in the same location.
1.3 SLI enabled: 90-111 FPS
1.4 SLI enabled: 22-35 FPS + bad microstutter while moving or simply moving the camera
1.4 SLI disabled: 34-50 FPS + bad microstutter while moving or simply moving the camera

Example 2: Alderaan, in the wild. All three measurements were made in the same location.
1.3 SLI enabled: 42-73 FPS
1.4 SLI enabled: 16-31 FPS + bad microstutter while moving or simply moving the camera
1.4 SLI disabled: 28-43 FPS + slight microsuttter while moving or simply moving the camera

Example 3: Jedi Knight Defender, Holocom room, character in front of the Holoterminal, door behind the character, camera looking at the character from behind the Holoterminal. All three measurements were made in the same location.
1.3 SLI enabled: 110-111 FPS
1.4 SLI enabled: 32-45 FPS + bad microstutter while moving or simply moving the camera
1.4 SLI disabled: 60-72 FPS + slight microsuttter while moving or simply moving the camera

The GPUs just aren't being utilized properly in SLi in 1.4. In 1.3, they were constantly utilized between 96%-98% per GPU, in 1.4 it's 30%-40% for each GPU.

I've tested with Nvidia GeForce driver versions 306.23, 304.79, 295.73 and some others, with little difference. Forcing Dragon Age 2 SLi compatibility bits (0x42400005 in Nvidia Inspector) helps a tiny bit (maybe 5-10 FPS in some situations), but performance is still abysmal in 1.4 with SLi enabled compared to it disabled or it enabled in 1.3.

Here are my full system specs:
Spoiler


In closing, this has been reported for Game Update 1.4 on the public test server. I can't comprehend why Game Update 1.4 went live even though Bioware knew about this issue before it was fixed. Bioware's/Electronic Arts' Quality Assurance seems to be non-existant.

By the way, how often do I have to tell Bioware it isn't a good idea to roll back to an old beta build that had some of the features you want to sell as "new"? You should work on the existing code and add things, instead of taking the unoptimized code base from one year ago and adding the stuff you've added since then onto it...Just saying. It looks like you rolled back to old code bases in 1.2 and you did it again in 1.4 (the "new" shadows, bad multi-GPU performance and moods and various bugs that were all in one beta build 1.4 is probably based on and miraculously resurfaced in 1.4 give it away!) - I guess you thought that there were too few of the old beta testers left to notice, huh? Don't be lazy and do things properly next time!

Update: The new Nvidia 306.63 drivers seem to help a little (in combination with the SLI compatibility bits set to 0x42C00005 / DiRT3 in Nvidia Inspector), but performance and GPU utilization with SLI enabled is still bad.

Gawlron's Avatar


Gawlron
09.26.2012 , 01:49 PM | #102
Quote: Originally Posted by AllisonBerryman View Post
Hey everyone - we're aware of some issues introduced in Game Update 1.4 that may cause frame stuttering or performance problems (particularly on CrossFire or SLi setups). If you are experiencing these problems, please try disabling shadows. We are working on resolving these issues, but disabling shadows in the meantime may result in a performance increase. If you notice a performance increase after disabling shadows, please post to let us know (as some of you already have). We'll update you if we have any more information to share as we work on this issue. Thank you!
Hi Allison, this was one of the first things I tried, it did not eliminate the problem, reduced it... but did not bring it back to the performance I had before the patch - which was everything set on high, plus some tweaks in NVCPL and v-sync turned on for a smooth 60FPS.

Windows 8 Pro x64 (RTM - OS Was released to MSDN and OEM on 8/15/2012)
i7 980x OC'd @ 4.33Ghz
3x GTX680 OC'd @ 1.1Ghz (WHQL 306.23)
KHX 16GB DDR3 @ 1.6Ghz
3x OCZ Agility 3 (240GB, 2x 120GB, NO RAID)
CE VIP
Emotion, yet peace; Ignorance, yet knowledge; Passion, yet serenity; Chaos, yet harmony; Death, yet the Force.

Omophorus's Avatar


Omophorus
09.26.2012 , 01:50 PM | #103
Quote: Originally Posted by AllisonBerryman View Post
Hey everyone - we're aware of some issues introduced in Game Update 1.4 that may cause frame stuttering or performance problems (particularly on CrossFire or SLi setups). If you are experiencing these problems, please try disabling shadows. We are working on resolving these issues, but disabling shadows in the meantime may result in a performance increase. If you notice a performance increase after disabling shadows, please post to let us know (as some of you already have). We'll update you if we have any more information to share as we work on this issue. Thank you!
Tried that. Didn't really help. The only fix was disabling CrossFire entirely.

Framerate improved somewhat, but still a ton of stuttering and still utterly unplayable.

solikepoison's Avatar


solikepoison
09.26.2012 , 02:00 PM | #104
Quote: Originally Posted by Gawlron View Post
Hi Allison, this was one of the first things I tried, it did not eliminate the problem, reduced it... but did not bring it back to the performance I had before the patch - which was everything set on high, plus some tweaks in NVCPL and v-sync turned on for a smooth 60FPS.

Windows 8 Pro x64 (RTM - OS Was released to MSDN and OEM on 8/15/2012)
i7 980x OC'd @ 4.33Ghz
3x GTX680 OC'd @ 1.1Ghz (WHQL 306.23)
KHX 16GB DDR3 @ 1.6Ghz
3x OCZ Agility 3 (240GB, 2x 120GB, NO RAID)
I turned off all shadows and put all my setting from medium to very low, frame rates still terrible

SoyChulo's Avatar


SoyChulo
09.26.2012 , 02:29 PM | #105
So I've had this issue on the PTS and now on live server.

The framerate is terrible, jerking all around, horrible performance.

I've turned off shadows, reduced textures, used low settings, etc. I've also turned off crossfire. NONE of it improves the performance of this build of the game. It is absolutely unplayable for a raider who needs to keep his group up as a healer.

This is disappointing as I mentioned this was an issue on the PTS. I was hoping that when the patch went live that it would not be a problem.

I run 6970 in crossfire.
<E> Guild - Progression raiding
Fun, casual or hard-core, players feel free to apply

Felioats's Avatar


Felioats
09.26.2012 , 02:35 PM | #106
I'm using an NVIDIA GeForce GTX 550 Ti -- a single one, not in SLI -- and I am experiencing the stuttering both with shadows on and off.

Oddly enough, framerates don't seem to drag at all. There's just stuttering.
>

Rogoo's Avatar


Rogoo
09.26.2012 , 02:37 PM | #107
Well, how exactly is it possible that this issue "slip through" even though it was reported as soon as 1.4 hit the PTS ?

Pandaria much ?
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.

Nimithril's Avatar


Nimithril
09.26.2012 , 02:44 PM | #108
Greetings,

I have no problems with FPS...sits right at ~60 like its supposed to with VSync on.

However, I experienced the stuttering problems. I disabled shadows, no change. Then one by one I disabled or turned to low all of the other graphics options and still had the stuttering. Then I noticed that the stuttering only occurs when moving the camera view in a vertical direction, never when strictly horizontal. I then tried disabling VSync and still no change.

I was running the game in Fullscreen mode, but then switched to Fullscreen (Windowed) and all problems were solved, plus my FPS went up, thought that really wasn't a concern.

The only caveat is that I have to keep Shadows on Low to prevent the stuttering.

Hope this helps some of you straighten things out.

Edit: The downside to this is that it makes my 560Ti run about 8 to 10 deg C hotter than usual.
Quote: Originally Posted by DarthAbominor View Post
And finally, sitting through this video is like watching a 6 year old bash his own head in with a frying pan.. just not as entertaining.
Quote: Originally Posted by nvoid View Post
That's my new facebook status: Shut up the f$·$%$% mouth!

magecutter's Avatar


magecutter
09.26.2012 , 02:48 PM | #109
the new shadow system seems to be working really really well. I've always turned shadows off and kept my graphics set at (custom) about mid level.

I've just today maxed all the graphics just to see what would happen and am getting very good fps ('bout 60 constant) even on the fleet. the environments are much improved and yes, the new shadow system makes a huge difference.

Well Done Shadow Dev's! Well Done Indeed !

Felioats's Avatar


Felioats
09.26.2012 , 02:53 PM | #110
Quote: Originally Posted by Nimithril View Post
Then I noticed that the stuttering only occurs when moving the camera view in a vertical direction, never when strictly horizontal.
If this is true, it might explain why why the stuttering happens almost constantly when riding an elevator.
>