Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Developer Update: Shadow Optimizations in Game Update 1.4

STAR WARS: The Old Republic > English > General Discussion
Developer Update: Shadow Optimizations in Game Update 1.4
First BioWare Post First BioWare Post

Rogoo's Avatar


Rogoo
09.26.2012 , 10:44 AM | #91
Quote: Originally Posted by Glzmo View Post
[COLOR="DeepSkyBlue"]Way to bring the borked SLI performance live, Bioware, even though it was reported before
Not only did they broke SLI. They also broke Crossfire.

So, once again, they screwed all the people with dual GPU rigs, yet they claim improved performance with the patch.

So much Biofail.
You are not your rig specs. You are not your K/D ratio. You are not your character level. You are not your sig.
Gunslinger / Shadow / Sentinel / Powertech
The Hero engine: a 2005 technology bringing 2013 rigs to their knees.

SenatorPalpaTANG's Avatar


SenatorPalpaTANG
09.26.2012 , 10:45 AM | #92
Quote: Originally Posted by Glzmo View Post
Way to bring the borked SLI performance live, Bioware, even though it was reported before. Why do you even put patches on the public test server when you ignore feedback and bug reports on critical issues like this and bring the patches live without fixing them? Having worse performance in 1.4 with SLI enabled than a single card is Inacceptable! On Tython, I had 90-110FPS with full details on my dual GeForce GTX 580 3GB SLI rig in 1.3, in 1.4 it's 20-35. On a single card in 1.4 with SLI disabled I get 35-50 FPS.

Bioware, why do you bring such buggy builds live even though you know of the issues?!

I am disappointed and mad at you.
Yep, running shadows on High last night I was capped at 60fps (V-synced). Log in today and I'm struggling to manage 30 at the same settings with my SLI 560 Ti cards...

Come on, Bioware.
VIGILANCE Rancor Rider

jugheadz's Avatar


jugheadz
09.26.2012 , 10:55 AM | #93
Same issue- 680GTX SLI now runs the game under 30fps with the new shadows. Turning them off and wow, over 100fps.

Please fix this because the game looks like crap without shadows (although it does play great now...)

AllisonBerryman's Avatar


AllisonBerryman
09.26.2012 , 12:30 PM | #94 This is the last staff post in this thread.  
Hey everyone - we're aware of some issues introduced in Game Update 1.4 that may cause frame stuttering or performance problems (particularly on CrossFire or SLi setups). If you are experiencing these problems, please try disabling shadows. We are working on resolving these issues, but disabling shadows in the meantime may result in a performance increase. If you notice a performance increase after disabling shadows, please post to let us know (as some of you already have). We'll update you if we have any more information to share as we work on this issue. Thank you!

Jaick's Avatar


Jaick
09.26.2012 , 12:45 PM | #95
Editing my previous response because said workaround only worked for maybe an hour before it got really choppy again.

SenatorPalpaTANG's Avatar


SenatorPalpaTANG
09.26.2012 , 01:02 PM | #96
To confirm, yes turning the shadows to low or off eliminates my performance problems.
VIGILANCE Rancor Rider

Savro's Avatar


Savro
09.26.2012 , 01:03 PM | #97
THis are my fps according to CTRL+SHIFT+F informations, I tested BH ship (so it is not dependent anyway from other people presence) and on the fleet

On the ship:
Shadows off: around 108 fps
Shadows low: around 108 fps (same as off)
Shadows high: around 80 fps
Yesterday i was around 108 fps with shadows on

On the fleet:
Shadows off: around 35 fps
Shadows low: around 30 fps
Shadows high: around 22 fps
Yesterday i was around 50 fps with shadows on


I have a ATI radeon HD 5700 updated to latest driver.

jugheadz's Avatar


jugheadz
09.26.2012 , 01:08 PM | #98
Did you guys try running the repair option? I started to experience a crash to desktop and couldn't log in so I had to run it. After doing so I just so happened to re-enable shadows and the game seemed to be running smooth again. See if it works for you.

After further testing this did NOT resolve my issue with shadows. Sorry!

Reginthorn's Avatar


Reginthorn
09.26.2012 , 01:28 PM | #99
Okay I am getting horrible frames even when I disable shadows. The game ran fine for me on Max before patch 1.4, but now the game still performs horribly ON VERY LOW settings. My GPU is a single 6970 and therefore should be able to handle this game.

i7-3770k
Radeon HD 6970
8GB RAM
7200RPM HDD

Khosann's Avatar


Khosann
09.26.2012 , 01:41 PM | #100
I have NVIDIA GTX 580 Core i7 950 and 8 GB RAM

With Patch 1.4 I have severe lag. Even if I disable shadows and select the lowest graphic options from game menu the problem persists. I had no issues before applying patch 1.4.

Note: Disabling ambient occlusion or enabling it at quality setting does NOT increase OR decrease my frame rate.
Enabling or disabling AA does not change FPS.

I run the game at highest settings at Full HD + NVIDIA ambient occlusion quality, negative LOD allowed, FXAA, NVIDIA 16 AF override and 8xCSAA, triple buffer.
There is no mistake.