Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

random disconnects then game closes

STAR WARS: The Old Republic > English > Customer Service
random disconnects then game closes
First BioWare Post First BioWare Post

EbassTekniq's Avatar


EbassTekniq
09.23.2012 , 12:13 PM | #1
when ever i play swtor, i get in game and everythings fine for a few minutes, then i lose connection, and my game just up and closes on me. what is happening ??

Tirvaak's Avatar


Tirvaak
09.23.2012 , 12:51 PM | #2 Click here to go to the next staff post in this thread. Next  
Hi EbassTekniq,

Could you clarify what you mean by lose connection? Do you mean get disconnected from your network or just the game?

Do you receive any error messages when this happens? When the game crashes do you notice a change in the ping on the signal bar in-game? Any extra information you can provide about this problem would be very helpful.

Thanks.

Tirvaak | Bioware Customer Service - Forum Support

EbassTekniq's Avatar


EbassTekniq
09.23.2012 , 01:52 PM | #3
i get disconnected from game and it puts me in the server selection screen with an error message (not sure what number) then when i hit the ok button on said error message the game just closes and puts me to my desktop screen

Tirvaak's Avatar


Tirvaak
09.23.2012 , 01:59 PM | #4 This is the last staff post in this thread.  
Hi EbassTekniq,

Thank you for confirming that for me, I'd like you to try the repair function from the launcher to see if this helps with your issue.

Exit the game and open the launcher again. Login as normal but do not press play. When the play button appears click on the cogwheel in the left corner of the launcher and select repair.

Once the repair has completed, click play and see if the problem has been resolved. If it does continue can you give me the error number that appears.

Let me know if this helps.

Tirvaak | Bioware Customer Service - Forum Support

Ghostlyshado's Avatar


Ghostlyshado
09.24.2012 , 02:37 AM | #5
Quote: Originally Posted by EbassTekniq View Post
i get disconnected from game and it puts me in the server selection screen with an error message (not sure what number) then when i hit the ok button on said error message the game just closes and puts me to my desktop screen

That would be error code 9000 followed by 2004 or 5 i believe i cant remeber. BW does not have a fix they will have you try many options until they just say call your ISP. But I hope you are a lucky one and one of their steps work . I am an unfortunate one so i guess i have to unsub again just like after game launch :/

Savro's Avatar


Savro
09.24.2012 , 03:01 AM | #6
The disconnect is not an intended behavior obviously but i can tell you that the "client restart after a disconnection" is an intended behavior as already CS told me before, when i asked the same question:

Quote: Originally Posted by Sutii View Post
Hello everyone,
Regarding the issue with a full client restart being required after the connection has been lost, unfortunately this is for security reasons and ensures that a secure connection is established by the account holder. I appreciate that this can be especially frustrating when you are in the middle of playing, however I can only advise that you head over to our Suggestion Box and share your thoughts there on how this may be modified in the future.

Thanks.

BBriddick's Avatar


BBriddick
09.24.2012 , 11:40 AM | #7
I seem to have the same issue. I login select my character and it either makes it in-game or boots me to server selection i re-select my server and it sometime lets me in game or boots me back to server selection.after about 20 times of this and 4 restarting the client i started monitoring my network connection to see if i was having packets drop but not a hiccup 0 packet loss. I tried the repair option but it isn't click-able. I am noticing when it starts kicking me out to the server selection it is generating a lot of loopback connections

BBriddick's Avatar


BBriddick
09.24.2012 , 12:03 PM | #8
it is also about every second or third disconnect switching me to a different server ip
159.153.65.229
159.153.65.197
159.153.65.212
159.153.66.19
since i started writing them down

159.153.92.42:443
159.153.72.197:443
159.153.65.210:8995

EbassTekniq's Avatar


EbassTekniq
09.24.2012 , 12:49 PM | #9
its odd because the problem seems to change or be more sevear in some aspects of it, seemingly random, but now it jsut lets me sit in the game, logged into a character, but i just cant move cause im lag blocked and it tells me i have 60k server ping, yet my internet connection is fine. seems very odd to me, and yes it is error 9000 and 2004 that i get sometimes still. ive run the repair, even tryed reinstalling the entire game, but to no avail. i love this game bioware DONT MAKE ME QUIT IT.

NightsideDemon's Avatar


NightsideDemon
09.24.2012 , 12:59 PM | #10
At least I'm not alone in this issue. I've been dropped 4 times today already with the following errors showing up, 2004, 2005 and 9000 all of which seem to be random at differnt drop times. Trying repair now to see how that goes.

Well, repair just finished so I guess I will try again.