Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Please Help, since last patch and "fix patch" I have major lag in game

STAR WARS: The Old Republic > English > Customer Service
Please Help, since last patch and "fix patch" I have major lag in game
First BioWare Post First BioWare Post

QQMcgoo's Avatar


QQMcgoo
09.15.2012 , 03:04 PM | #1
Since the last patch I have major lag in game. The next day a "fix" was patched. I did not help me at all. I have been playing the game since beta and have never had issues with any lag what so ever. Over the last week I cant even play wz's at all and everything takes forever to load. I realize things take time, but it is really frustrating to have this issue. I know it is the game and not my laptop. I havent changed anything and run a high end laptop. Please advise.

QQMcgoo's Avatar


QQMcgoo
09.15.2012 , 04:02 PM | #2
I am now unable to get past the log-in screen. I log-in and then it is stuck loading...... Please help.

Bronholz's Avatar


Bronholz
09.15.2012 , 04:12 PM | #3 This is the last staff post in this thread.  
Greetings QQMcgoo,

We are aware that this login issues is effecting a large number of our players and we are currently asking players to provide us with information in this thread.

If you can provide the information requested there it will help us look into this issue.

Thanks for your patience.
Bronholz | BioWare Customer Service Forum Support

QQMcgoo's Avatar


QQMcgoo
09.15.2012 , 04:12 PM | #4
I just attempted to call the support number. After going through the 3 minute process of getting to the right area I then hit opition 3 to talk to a rep. and then it tells me I have dialed the wrong number.......