Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Adv Class Bug [Jedi Knight]

Arcwave's Avatar


Arcwave
12.19.2011 , 12:40 AM | #1
I'm a Jedi Knight, level 16, and I didn't select my adv class at lvl 10 -- but now when I go and visit the trainer at the Republic Fleet he tells me he has nothing to say... I cannot train with him. What's going on?

Rohrnin's Avatar


Rohrnin
12.19.2011 , 12:44 AM | #2
Did you visit the Jedi First who gives you your 'quest' to go see your advanced trainer? He tells you all about your one of two paths you are about to take, etc.

Then you go to see the advanced trainer, then you go to your trainer.

I know. Fun ain't it?

Arcwave's Avatar


Arcwave
12.19.2011 , 12:45 AM | #3
I just figured this out... Hah! Thanks so much. Issue resolved

Emerie's Avatar


Emerie
12.19.2011 , 12:45 AM | #4
Are you going to the Jedi knight trainer or the advanced trainer? the advanced trainer is pretty much only for choosing your advanced class. But you need the quest for it to do it. I'm not 100% sure where the guy that give you the quest is, but i think there's one in coruscant between the flight path and senate tower and another one right when you come out of the docking place from tython to republic fleet.

If you want to train your advanced class skills then you go to the jedi knight trainer and change the tab to guardian/sentinel at the bottom, but you have to choose adv class first.

Jaslm's Avatar


Jaslm
12.19.2011 , 05:01 PM | #5
I made the mistake of cancelling out of the advanced training dialog for my level 11 Jedi Knight and now I'm stuck. I don't have an advanced training specialty -- don't have the initial quest any longer and can't pick it up. The advanced trainer tells me that I have chosen my path -- lol. I filed a ticket with customer support a few days ago, and that was just marked 'closed' today, but nothing has been resolved. Very frustrating.

Aha! My husband just found a solution. Bringing up the talent tree showed the dialog that had initially appeared from the advanced class trainer -- with 'Inspect' and 'Select' options. I was able to select my specialization there and now all is hunky-dory.