Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

WTH is going on with the servers?

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
WTH is going on with the servers?
 

Wildjenna's Avatar


Wildjenna
12.19.2011 , 02:41 PM | #1
All week long ive been at 100 latency and this morning just fine. And then i get something to eat and come back at noon and the server has turned to crap. Im sitting at 240 latency and jumping to 700 every 30 seconds and spiking at 5k or higher. I even just got disconnected from the server cause i lagged out.

Now im hoping this is all because you guys are messing with the servers getting ready for tonight...

Fizzed's Avatar


Fizzed
12.19.2011 , 02:42 PM | #2
I'm getting the same thing. My Server Lag bars are going up and down like crazy.

Jonch's Avatar


Jonch
12.19.2011 , 02:43 PM | #3
Same problem, and warzones in general have been afk the whole time

Beetlebub's Avatar


Beetlebub
12.19.2011 , 02:43 PM | #4
Looks like a ton of people are having the same issue, there are a few other threads about this issue in the Customer Service forum.

Wildjenna's Avatar


Wildjenna
12.19.2011 , 02:44 PM | #5
This is really frustrating because i was wanting to get quite a bit of progress today before the rush of all the noobies D:

Stonedruid's Avatar


Stonedruid
12.19.2011 , 02:46 PM | #6
Same here, never had latency above 200 except for once on Taris and Coruscant during beta. Today Shien is sitting somewhere around 350 during a good moment, and spiking to 13000 and above every ten minutes or so. Doing the disconnect rhumba here...
In the immortal words of Socrates... "I drank what?!"

Wildjenna's Avatar


Wildjenna
12.19.2011 , 02:52 PM | #7
And disconnected yet again. I couldnt attack this mob but he sure as hell killed me.

Oh how much fun this is right now..

Thram's Avatar


Thram
12.19.2011 , 02:52 PM | #8
Played fine for days and today it is unplayable due to latency and disconnects