Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Unable to launch the game...

LukeMapley's Avatar

12.19.2011 , 02:18 PM | #1
I know there have been several threads about this with varying symptoms and loads of different responses but I've tried absolutely everything that I've read and I've re-installed several times with no joy. So I thought I'd post my exact problem(s) and hope that someone can tell me how silly I am and give me a nice and simple solution :-) I installed the game on my old laptop and it worked fine other than the PC was not powerful enough to run the game smoothly so I bought a new laptop and now cannot play...

My problems:

1) When I run the programme after installing I do not have the "repair" button under the settings bit at the bottom left of the screen that I should have. On my old laptop I have this option plus another one that says about running test client or something like that. Now I can only change the language in the settings bit, nothing else.

2) I click "play" and the poster screen comes up then just closes down after about 5 seconds. No error message or anything.

3) On 2 occasions it has actually got past that screen and made it to the "select server" screen, unfortunately the servers don't appear on the screen so can't go anywhere. This has only happened twice out of lots and lots of attempts.

I have sent my dxdiag with no response yet and have tried lots of suggestions like running as admin, turning off firewall and AV etc but no joy. Can anyone help???

PS: I am useless with computers so simple and basic words would be appreciated :-)