Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Mouse right click becomes unusable after 4 hours?

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Mouse right click becomes unusable after 4 hours?
First BioWare Post First BioWare Post

Metalmac's Avatar

08.13.2012 , 06:07 PM | #1
I play all day as I am retired so when I log on I have noticed that after 4 hours of SWTOR my right mouse button just stops working, and it does not matter what mouse I am using and I am using the WINDOWS 7 GERERIC DRIVER.
And yes it is current (Dirvers up to date) and yes it works fine in any other game EXCEPT SWTOR.

I was told this was being investigated but this has to be a interface issue in the game.

Anyone else get this problem?

Speire's Avatar

08.14.2012 , 12:40 AM | #2 This is the last staff post in this thread.  
Hi Metalmac,

Have you tried settings the mouse options to default via the in-game configuration panel?

This could resolve your issue but if not, don't hesitate to come back to us.


Speire | Bioware Customer Service - Forum Support

Krippler's Avatar

08.16.2012 , 04:08 AM | #3
I ran into this as well. The last couple of days after playing a bit and working on my dailies. I lose the ability to right click. The only solution I've found it to completely log out of the game to get my mouse to work again.

I've tried swapping my mouse with a new one and changing my one function key to right click.on my keyboad. Both did not fix the problem.

I did put a ticket in about this but I'm not sure if they will respond with anything good. The last 2 evening that I've played I was on Belsavis in the first cave doing the one where you need to retreive the munitions crates and you kindof need that ability to finish the mission or any misssion.