Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

"The catalyst" quest on Taris

Vookie's Avatar

12.19.2011 , 06:03 AM | #1
Hey all,
I had a bit of trouble doing this quest as i couldn't seem to get infected. But then i tried abandoning the quest and accepting it again, and all of a sudden I got infected on first try.
I think my problem was that i had loggede out in between accepting the quest and trying to do it.
Therefor if anyone have the same problem, try to abandon it and re-accept it... Worked for me :-)

LokenKreig's Avatar

12.19.2011 , 07:53 AM | #2
If you just reset the quest on the mission log that can fix it as well.

Ashmadai's Avatar

12.19.2011 , 08:46 AM | #3
I was grouped with my wife for this. I got infected on our 2nd group of Rakghouls. She wasn't getting infected after another 10 minutes, so she opened her log and just hit the reset button for the quest, and then it worked immediately. I saw others in general chat having a similar issue.

Chronnya's Avatar

12.26.2011 , 05:09 AM | #4
Quote: Originally Posted by LokenKreig View Post
If you just reset the quest on the mission log that can fix it as well.
I can confirm that resetting the quest worked for me

Wanada's Avatar

12.26.2011 , 10:35 PM | #5
Was having issues getting infected as well. Tried resetting, and I was finally able to get infected on my 3rd group after that.

Guldlysing's Avatar

12.28.2011 , 01:08 AM | #6
My problem was that I got infected but the quest didn't update. I did reset and it worked find then.

EchoTwoOmega's Avatar

12.28.2011 , 01:15 AM | #7
Not sure if the quest is bugged or working as intended HOWERVER the player that wins the roll during the conversation and gets the injection is the ONLY one that can get infected. Any other players in the group will be unable to complete the quest.
Squadron 367

DeadCenter's Avatar

01.04.2012 , 09:08 PM | #8
Same. Reset the mission after all my attempts to complete it failed. Then went to the map marker & still couldn't get it. It's cuz I had to wait for a red one to respawn. He got my companion first, so I sent my companion off & when I got hit by the red one next I was infected first try. Thanks for this thread. Solved my frustrations with this mission.

sarsbretta's Avatar

01.04.2012 , 10:26 PM | #9
Resetting the mission worked for me too.

Arodin's Avatar

01.04.2012 , 11:51 PM | #10
Same thing here-- I also logged out after picking up the quest and found it broken when I came back.

Hopefully Bioware sees this, another bug that needs fixing.