Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Descent class quest bug (Spoilers)

STAR WARS: The Old Republic > English > Classes
Descent class quest bug (Spoilers)
First BioWare Post First BioWare Post

IsletsReborn's Avatar


IsletsReborn
07.08.2012 , 01:11 PM | #1
Im wondering if anyone else has experienced this issue. What happens is after i use my holoterminal and its time for me to board the emperors space station i click leave ship and it kicks me to the character select screen. Ive tried relogging and opening a new launcher neither worked.

Jue-Bria's Avatar


Jue-Bria
07.08.2012 , 02:05 PM | #2
Quote: Originally Posted by IsletsReborn View Post
Im wondering if anyone else has experienced this issue. What happens is after i use my holoterminal and its time for me to board the emperors space station i click leave ship and it kicks me to the character select screen. Ive tried relogging and opening a new launcher neither worked.

Got the same problem here.
Jue

AmberGreen's Avatar


AmberGreen
07.17.2012 , 10:47 AM | #3 This is the last staff post in this thread.  
Hello there! Thanks for reporting this, and your reports are currently being investigated. Please post in this thread if you continue to experience the issue, have a resolution, or would like to add additional information about this Class mission.
Amber Green | Live Services Specialist
Follow us on Twitter @SWTOR | Like us on Facebook
[Contact Us] [Rules of Conduct] [F.A.Q.] [Dev Tracker]