Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Launcher does not work

First BioWare Post First BioWare Post

Slowpokeking's Avatar

06.30.2012 , 05:07 PM | #1
Today I clicked it but it does not work at all, I can see it in the process but nothing pop out.

Hawath's Avatar

06.30.2012 , 06:15 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Slowpokeking,

In order to attempt solving your issue please follow the steps listed below:
  • Restart your computer to make sure the launcher.exe is not started or end the process in task manager.
  • Delete the "Patch" folder and "patcher.version" file located at “C:\Program Files (x86)\Electronic Arts\BioWare\ Star Wars - The Old Republic\”
  • Delete “Launcher.exe” located at “C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\” and then run "Fixlauncher.exe" in the same directory.

    If you do not have "Fixlauncher.exe", please install the game client from After this has been done please open the Launcher which will have a red bar saying that it is updating and then restart, when it does login and play the game.

Please let us know if your problem is not solved afterwards.

Hawath | BioWare Customer Service - Forum Support

afoconnor's Avatar

07.01.2012 , 10:44 AM | #3
I have had similar problems with my launcher as it will not load and i have tried some of the solutions in the troubleshooting guide. And i have tried to use the fixlauncher however it only gets about 90 percent complete and then it says this : Cannot create avcodec-53.dll
Cannot create avformat-53.dll
Cannot create avutil-51.dll
Cannot create chrome.pak
Cannot create icudt.dll
Cannot create launcher.exe
Cannot create libcef.dll
Cannot create locales\en-US.pak
Cannot create SWTORLaunch.dll

this problem started the day after patch 1.3 came out
can u help

Hawath's Avatar

07.01.2012 , 02:32 PM | #4 This is the last staff post in this thread.  
Greetings afoconnor,

Please go to and download the setup file again and run it. (Please run the application as Administrator and add an exception for SWTOR_setup.exe to your firewall and anti-virus software)

This will reinstall the Launcher, it will not download the game content again.

You should also check that you have the latest Service Pack and Windows Updates installed for your operating system, including the optional updates such as .NET framework and Visual C++ features.

We hope this resolves the issue for you! If not do not hesitate to let us know.

Hawath | BioWare Customer Service - Forum Support