Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Unable to Patch launcher or game *SOLVED*

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Unable to Patch launcher or game *SOLVED*

Ralpht's Avatar

12.18.2011 , 12:48 PM | #1
Windows 7 x64
For some reason the game would not patch this morning. I ran fixlauncher, and after that I was unable to patch the launcher either. I could download the files listed in the logs through my browser, but the program appeared to download them (as .partial) but was unable to proceed after that.

I tried safe mode, turning everything off (firewall and av), Running as Administrator.

What finally worked for me, was to go into services, set the DNS Client to Automatic and start it, then go to a command line and run ipconfig /flushdns. Why DNS Client was off, I have no idea.

Sorry for the abbreviated steps here, but this worked for me.

I don't know if I was pointed to a currupt CDN server or if some other strange thing was going on. It's also possible that the CDN server was updated at the same time that I started the service (i <heart> Murphy.)

Hope this helps someone.