Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Server is up...but says log in service unavailable?!

STAR WARS: The Old Republic > English > Community Content
Server is up...but says log in service unavailable?!

roaronoa's Avatar


roaronoa
05.31.2012 , 03:40 PM | #11
same here.

Warrarri's Avatar


Warrarri
05.31.2012 , 03:42 PM | #12
And STILL no info.
------------=WARR=-
Strength - Honor - Sacrifice

----------------

xJACKTHERIPPERx's Avatar


xJACKTHERIPPERx
05.31.2012 , 03:48 PM | #13
back up now.

1.2.5 Patch Note Addendum
5/31/2012
General

Corrected an issue that caused the in-game version number to display incorrectly.
Made improvements to optimize texture loading.
<Prophecy of the Five> Munda - 55 Sniper | Seever - 55 Juggernaut | Kasra - 55 Assassin | Vasius - 55 Mercenary | Innoss - 55 Sage | Sediya - 55 Vanguard | Yellow'Polka - 55 Sentinel | Vi'da - 55 Scoundrel

Tendenciez's Avatar


Tendenciez
05.31.2012 , 03:48 PM | #14
wouldn't it be nice if there was a forum Mod watching over issues that might appear in the forums...as the players are not able to log in. At least some sort of response or information about the problem would be something.....

Eillack's Avatar


Eillack
05.31.2012 , 03:49 PM | #15
There is an ongoing thread about this.
With unity, comes strength...with strength, comes power...with power...comes obedience.....
CE Owner '09 Account
Quote: Originally Posted by BruceMaclean View Post
..I think it's ultimately our fault for not communicating enough.

WTFsandwich's Avatar


WTFsandwich
05.31.2012 , 03:49 PM | #16
I like to think they're not responding because they're fixing it.

Though that's probably wishful thinking.

Eillack's Avatar


Eillack
05.31.2012 , 03:51 PM | #17
Quote: Originally Posted by WTFsandwich View Post
I like to think they're not responding because they're fixing it.

Though that's probably wishful thinking.
They are working on it. Some people (including myself for now.....) have gotten the launcher to work again.

http://www.swtor.com/community/showthread.php?t=469018

For me, it took many attempts to login.

I truely wish the best of luck to everyone.
With unity, comes strength...with strength, comes power...with power...comes obedience.....
CE Owner '09 Account
Quote: Originally Posted by BruceMaclean View Post
..I think it's ultimately our fault for not communicating enough.

Tendenciez's Avatar


Tendenciez
05.31.2012 , 03:51 PM | #18
appreciated

Fomby's Avatar


Fomby
05.31.2012 , 03:52 PM | #19
Quote: Originally Posted by Schyzo View Post
Same here. All i get is " The login service is currently unavailable. Please visit our forums for the latest updates on the status of the service." I've tried everything and no luck.
This. I love this.

scoobasteveo's Avatar


scoobasteveo
05.31.2012 , 03:58 PM | #20
i cant get past the loading screen after the character screen
Proud member of THE Brotherhood