Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

The Foundry - Assassin Droid boss bugged?

DaftMule's Avatar


DaftMule
05.16.2012 , 02:38 AM | #1
Weird things happening last night when we did the Foundry and tried to take down the Assassin Droid boss:

1. At times it seemed the droid adds were continuously spawning in a relentless stream. It wasn't that we weren't killing them fast enough as on other runs, we all had time between add spawns, when he telports back to his column, to catch our breath a bit.

2. On several occasions during our attempts, the Assassin droid would not make it back into his regeneration column thingy. The target reticle would appear some place outside the column and then he would just teleport to the reticle and stand there. The column would then come down with him outside it.

I still find it remarkable how hard this boss is compared to everything else in the Foundry. The final boss is a pushover by comparison and we barely broke a sweat on him! Not that I'm complaining though as it's nice to actually come across a boss that challenges you. They are way too rare in all the normal mode Flashpoints IMO.

Darth-Malice's Avatar


Darth-Malice
05.16.2012 , 03:01 AM | #2
It's been bugged since Beta and even after Bio-ware said they fixed it it's still broken. Don't expect a fix anytime soon.
||||||||███████████████████████████████)