Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher crashing

First BioWare Post First BioWare Post

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:00 AM | #1
I noticed that servers were back up, and was able to get halfway through the patching process when the download stopped. I tried to restart the launcher in order to get the download going again.

After restarting the launcher and logging in, I got an error message from Windows:

Quote:
SWTOR Launcher has stopped working

A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.
Then my only option is to close the launcher.

I keep getting this error message every time I login on the launcher. Restarting my computer didn't seem to help. Is anyone else having this issue?

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:07 AM | #2
Nevermind, it's not crashing anymore. I'm just having the normal "Network error while downloading patch data." issue. P:

(I have already followed all the instructions on the Launcher Troubleshooting Guide [http://www.swtor.com/community/showthread.php?t=419492]. I normally resolve this by repeatedly restarting the launcher...)

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:09 AM | #3
Ah, I just tried to restart the launcher, and after logging in again on the launcher, it crashed while trying to Resume the download.

This is what happened the first time too: the launcher crashed when it attempted to resume download.

Bronholz's Avatar


Bronholz
05.10.2012 , 04:10 AM | #4 Click here to go to the next staff post in this thread. Next  
Greetings ZenithStorm,

Have you tried running the FixLauncher application?

You can find this here:

C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic

Do you get any error other then the 'Stopped working' one?

Thank you for your continuing patience in this matter.
Bronholz | BioWare Customer Service Forum Support

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:12 AM | #5
Thanks for the quick response.

...whoa, I didn't know there was a FixLauncher program. Yes! Maybe this will fix everything! Trying it now; thank you. :3

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:25 AM | #6
I ran the FixLauncher program and restarted the launcher. Now it is stuck on "The Launcher is being updated. Please wait..."

Something to note: whenever the Launcher has issues downloading a patch or apparently updating the launcher, I start having connection issues with my internet. (I mean, I normally never have connection issues, and these connection issues only ever happen once the Launcher gets stuck downloading or something. This has happened almost every time I try to download patches... as mentioned above, my only "fix" has been to restart the launcher multiple times.)

Has anyone else had this issue? It seems kind of strange that the Launcher would affect my connection. (When I say that lose connection, I mean that all other programs that require internet connection [Google Chrome, WoW, etc.] claim that I don't have network connection, even though my computer says that it has network access.)

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:29 AM | #7
I'm just going to leave the launcher on all night doing it's "The Launcher is being updated. Please wait..."

Maybe it'll be done when I wake up in the morning. :D

Bronholz's Avatar


Bronholz
05.10.2012 , 04:30 AM | #8 Click here to go to the next staff post in this thread. Next  
Concerning the 'Launcher Updating', you may need to allow the Launcher to sit for awhile updating.

Have you allowed the launcher (launcher.exe) and game client (swtor.exe) to communicate through your firewall. For the Windows firewall you can check the following guide:
http://windows.microsoft.com/en-US/w...ndows-Firewall.
For other third-party firewalls, please refer to the software manufacturer for specific instructions on adding exceptions to those firewalls. This may be part of the network issues you are having with the launcher.

Thanks.
Bronholz | BioWare Customer Service Forum Support

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:32 AM | #9
The launcher appeared to have finished updated! It just restarted itself and I logged in on the Launcher.

Unfortunately, this did not solve my previous problem. It just crashed again when it tried to resume the patch download. (On "Resuming English Assets 59 0.02MB remaining")

ZenithStorm's Avatar


ZenithStorm
05.10.2012 , 04:36 AM | #10
I have already allowed swtor and the launcher through the firewall. It is checked on the list. Is there another way to make sure that they aren't being blocked?

Update on the situation: The launcher didn't crash this time. It's stuck at the usual "Network error while downloading patch data. Retrying..."