Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

MSVCP90.dll is missing. Help.

First BioWare Post First BioWare Post

KeyworkPredator's Avatar

05.03.2012 , 08:55 PM | #1
The program can't start because MSVCP90.dll is missing from your computer. Try reinstalling the program to fix this problem.

Had that error, couldn't get rid of it. So I reinstalled.

Ran the launcher again, patched up to 1.2, and now whenever I hit, "Play" I get that same error every time. I've googled and even tried reinstalling the Microsoft Visual C++ 2008 file like recommended. I've tried running as admin, I have ran the fixlauncher. I have done memory tests. Someone throw me a bone here. This is ridiculous.

Any help here? I'm running out of options and patience.

Bomyne's Avatar

05.03.2012 , 09:35 PM | #2 This list should help.

Step 4 says reinstall the program that uses this file. That'd be SWTOR. If you haven't already, try uninstalling and reinstalling the game.
RIP Star Wars


KeyworkPredator's Avatar

05.04.2012 , 06:51 AM | #3
I already did reinstall, I said that in the second line :P

I guess I may have to just reinstall windows, which is not on my want-to-do list

Smaois's Avatar

05.04.2012 , 06:54 AM | #4 Click here to go to the next staff post in this thread. Next  
Greetings KeyworkPredator,

For assistance with this issue, please send an email to with a full explanation of the issue and the troubleshooting carried out and attach your most recent Launcher log and also your MSINFO.

To get your MSINFO:
  1. Press Windows Key + R
  2. Enter into the following window “MSINFO32” and press ENTER
  3. Now you have the “System Information” open
  4. Click on “File” -> “Export” and save the file at any location convenient (default: Desktop) All this information must be saved as .txt file.
Our technical support team will be able to investigate this further for you.

Smaois | BioWare Customer Service Forum Support