Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Error Code: c7 Incompatible system.

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Error Code: c7 Incompatible system.
First BioWare Post First BioWare Post

Bladehamster's Avatar

04.23.2012 , 05:17 AM | #11
Please kindly help.
†¶▓╬╬╬╬║▓]▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀ị† "Patience, Use the Force, Think" Proud Owner of the CE

blwko's Avatar

04.25.2012 , 11:03 AM | #12
Thanks, I got rid of this terrible mistake by following your instructions

Scerion's Avatar

04.25.2012 , 05:00 PM | #13
Quote: Originally Posted by RaineGaming View Post
nothing? hello customer service?
I can tell you the problem - you're using an ancient machine with an 8 year old graphic card & far too little video memory. Where did you dig that thing up from?!

Xanaduu's Avatar

04.29.2012 , 08:14 AM | #14
I keep getting the following error:

This program encountered an internal error and will exit. Error code: C7
Incompatible system. Please verify your system is compatible with this game.
- - - - - - - - - - - - - - - - - - - - -
I am using a MacBook Pro with a partitioned harddrive that has a Windows 7 Ultimate version on it. The following information pertains to my computer:

Beesodd's Avatar

04.29.2012 , 08:24 AM | #15 Click here to go to the next staff post in this thread. Next  
Greetings Xanaduu,

In your case, your Windows is not detecting a graphics card correctly. "Card name: Standard VGA Graphics Adapter" indicates this. Reinstalling your graphics drivers may help.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

bigdaine's Avatar

04.29.2012 , 02:19 PM | #16
Same error here, can't start the game.

1. no SWTOR folder in Assets folder
2. tried to repair the game files too
3. deleted before the SWTOR folder in my user's localappdata folder
4. My CPU handles SSE3
5. I tried to replace my PlatformInfo.dll file from a working friend's computer's game
6. I tried to install DirectX 9 runtimes

I tried these solutions too :
One of the common issues here is if your graphics drivers aren'tup-to-date. If your graphics driver doesn't support the Direct3D Shader Model 3, this error will happen. So, double-check that your graphics drivers are current first, because that's the easiest fix. Unfortunately, if youdon'thave a dedicated GPU (i.e., if youdon'thave anNvidiaor ATIgraphics card) youprobably won't beabletoplay.
If you are on an ATI-based Mac using Bootcamp, the drivers included with Bootcamp do not always work and may trigger the issue. You can hit up AMD's GPU driver download page and pick specifically the Mac/Bootcamp option and the appropriate version of Windows; the drivers AMD will give you from that page are known to work properly withSWTOR.
If your card is definitely good and your drivers are current, this can also be caused if your .NET Framework is out-of-date or if you have an older version of DirectX installed, so hit up Windows Update just in case. And one last possibility is that your copy of PlatformInfo.dll is missing from the installation (or corrupted). If that'sthe case, you can try reinstalling, or youmight beabletoget a copyfrom a friend'sinstallation ofthe game.
Another issue is apparently if you use ASUS GamerOSD to allowoverclocking of your GPU, something in that program conflicts withthe system check and can cause the Error Code 7 issue to surface. In general, if you are running anything you don't absolutely require for the computer to function, youshould probably try quitting it to see if itwas causinga conflictwiththe game. You can even try a Clean Bootjust tobesafe.
Unfortunately, those don't seem to be the solution for everyone. The CS droids are aware of that, and are trying to collect information for the developers in this thread, where they'll alsopresumablyprovideupdatesonany fix. If everything is current, you'll want to check over there

Its not to install the latest 296.10 nvidia driver, instead use the latest one on asus' page.
Also uninstall all the C++ redistributables leaving only the one SWTOR uses, the 2008 one.
EDIT : Seems removing Asus GamerOSD, rebooting and starting the game solved the issue! I posted above what I found on the internet, so it can help others to fix it. Thanks also to Exca who fixed it for me


exca's Avatar

04.29.2012 , 05:50 PM | #17
You're welcome
Server : Darth Nihilus (FR) Characters : Exca, Universe Guild : Escadron Nemesis
Dev de : SWTOR Unleashed (FR) - augmente la fluidité de SWTOR
Dev of : SWTOR Unleashed (US) - raises SWTOR fluidity

iAmIsreal's Avatar

05.18.2012 , 10:27 AM | #18
I'm having an issue with a "C7 Incompatible System" as well.

Everything was working fine until one night my game jumped right to my desktop, and I recieved a windows error message stating: "This program encountered an internal error and will exit. Error code C7". I believe my system meets the minimum requrement: (OS Windows 7 [64 bit], 8GB RAM, i7 processsor)

1) I've tried uninstalling and reinstalling the game, that didn't work

2) I've tried installing Directx 11 again, that didn't work

3) I've tried installing a 64 bit Flash Player again, that didn't work

4) I don't have an ASUS GamerOSD

Any help would be much appreciated

mimorta's Avatar

06.21.2012 , 02:01 AM | #19
C7 error

Cerimon's Avatar

06.21.2012 , 02:17 AM | #20 Click here to go to the next staff post in this thread. Next  
Greetings iAmIsreal and mimorta,

Please run the launcher with administrative rights by right clicking on the shortcut and choose run as administrator in the compatibility tab of its properties.

Please also run the launcher in compatibility mode for Windows XP Service Pack 3.

Please post again if the issue persists.

Thank you for playing Star Wars: The Old Republic

Cerimon | BioWare Customer Service - Forum Support