Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Red Blade Codex Entry

Graverobbin's Avatar

02.29.2012 , 06:10 PM | #1
Is this bugged? Long story short, I can't find it.

Graverobbin's Avatar

02.29.2012 , 07:21 PM | #2

Mando's Avatar

03.04.2012 , 02:22 PM | #3
Its bugged i guess, dont have it either. Really annoying. Bioware needs to fix!

Schacherl's Avatar

04.28.2012 , 02:21 AM | #4
Very annoying. Even after all this time, the Red Blade codex entry still doesn't seem to be working ... Not a big deal for most people, but I have decided to really enjoy the alt and collect all the entries. Makes it less enjoyable if some codex entries are bugged ...
"The ability to destroy a planet is insignificant when compared to the power of the Force!"

Kiraleigh's Avatar

11.23.2015 , 01:49 PM | #5
in patch 4.0.2 for KotFE. they finally fixed it, only took about 2.5 years. Great for new agents what about the existing ones? How do we go back to get the codex entry? Tried logging in on my agent hoping it would just pop when i logged in, no such luck though.