Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Customer Service......BWAHAHAHA......NOPE

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Customer Service......BWAHAHAHA......NOPE

Semicool's Avatar

12.17.2011 , 12:03 AM | #1
Hi. Your customer support is worthless. I forgot one of my security questions (yes, i know....stupid move, bugger off) and have attempted to reach out to the team via their support email to get this resolved. I have offered to verify the pre-order code, the game code, the debit card information used to purchase the game, even down to my first born with no luck. All I get back is a snarky email (TWO days after i sent in the request) telling me they cant help me and I need to call the support line. OK, annoying yes but I can do this. For the last THREE days, I have attempted to call the support number only to hear some recorded message telling me that they are far too busy to take my call and then hangs up. i understand you may be busy due to the launch, but how was this an "unexpected" amount of calls? Based on the estimated amount of pre-orders, why did you not staff accordingly? After calling repeatedly this evening....i am now on hold for over 55 minutes just to gain access to MY account and am still waiting. Ok, thanks for letting me rant. I will return to my pit of sadness and empty beer bottles.


SoftballDad's Avatar

12.17.2011 , 12:08 AM | #2
I second this. I had almost the exact same experience. The sticky says you have to talk to a rep to reset, and of course there are NO reps answering the phones or emails.


Semicool's Avatar

12.17.2011 , 12:29 AM | #3
Just want to point out.......going on 90 minutes waiting for someone to pick up.........WORTHLESS!

Kryhavocwar's Avatar

12.17.2011 , 12:48 AM | #4
I work as a CSR in Real Life and I am extremely disappointed at the level of service being provided. Yes, I realized there would be problems with startup and at each hiccup, I eventually resolved it on my own without any live help from a CSR.

Now, I seem to have hit a major roadblock where the game crashes soon after I start it. My first start got me to what seemed to be the end of the Intro Cinematic and I was expecting to get to the Character Creation screen when the game crashed.

Each attempt to start the game after that crashes during the very first game screen, the one before the Bioware/EA/Lucasarts appear.

The people recording the message need to slow down and speak more clearly. It sounds like they recorded the message on a speakerphone and they are hard to understand.

Chloic's Avatar

12.17.2011 , 12:59 AM | #5
My personal favorite is the automated attendant that keeps telling me "My issue has been resolved" prior to booting me from the queue! Pure awesome, that!

I was stupid enough to remain on hold for just over 3 hours for the SQA issue before calling it a night...God bless vodka.

rickpArry's Avatar

12.17.2011 , 01:03 AM | #6
OK, this may or may not work for you.
this will get you logged into your account, but you may or may not be able to log into the game through the launcher, it worked for me but not for other people.

1. reset your password
2. after you have gotten the email and have a put in a new password (or the same old one, it doesn't matter) click ok in the window that says something like "you have been logged out for security reasons."
3. next, open up a new tab and go to click login, and put in your username and password. when you reach the part where it asks you for your security question, go back to the first tab that you clicked ok in.
4. on the first tab, click back in your browser. you should now be at the "you have been logged out for security reasons" page. click the ok button and you should be logged in!!!

this is where it stops working for people:
first off, dont bother trying to reset your security questions, because it will ask you for a security question lol. feel free to try and answer, although if you answer incorrectly you will have to repeat this process. Now, make sure you are logged in to your account, and open up the swtor launcher. try to login, although some people were still faced with the security question again. if this happens, the only think i can think of that you could do is repeat this process several times and hopefully swtor will recognize your IP adress ans stop asking you the questions, like it did for me.

hope this helps

TraanReith's Avatar

12.17.2011 , 01:09 AM | #7
Longest wait time so far, when I could get into a queue, was Two Hours and Twenty Four Minutes, before being disconnected. I have tried over fifty times in the past few days to get help via the phone line, and it's completely useless. I'm probably going to skip out on my preorder as a result. Why buy a game, and take it home, when I can't play because they won't help me fix my account?

Especially since the problem is with them, and not me! Did you notice how the opening message after you choose your language, when they don't just auto hand it to you in all three before disconnect, is how the "security question issue should now be fixed"? Such utter lies.

I'm just really frustrated since the rest of my guild also has early access and is in game already.