Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Switching Resolution

Brusana's Avatar


Brusana
12.14.2011 , 12:14 AM | #1
My computer sucks so I'd rather not have the game run at 1920x1200, but when I attempt to change the resolution using the in game menu the game screen goes black for longer than the timer before the game auto reverts is active. Is there a way to disable the timer or edit my resolution out of game?

bliapis's Avatar


bliapis
12.14.2011 , 12:19 AM | #2
Maybe you can try locating the settings file and then the resolution entry and manually change it.


Worths a shot

Yasmine's Avatar


Yasmine
12.14.2011 , 12:21 AM | #3
Try changing your Refresh rate from 100Hz to 60hz. That's been solving most peoples problem. I unfortunatly did not find this out until I had changed back to fullscreen and now have to uninstall and reinstall in hopes of being able to put the damn game back into a windowed mode. Customer service is a joke, don't hold your breath for them to help you.
Caelitus Sith Inquistor Collector Edition Preorder
I used to be part of the community. Now I'm just Bisexual

Ikitome's Avatar


Ikitome
12.14.2011 , 12:54 AM | #4
Anyone know where to do this outside of the game? My monitor apparently doesn't like the default and won't display anything.

Edit: Found in Star Wars the Old Republic > swtor > retail client. Open the file labeled client_defaults change FullScreen=true to FullScreen=false.

Game will launch, once in the game edit settings and change refresh rate from 100 to 60 (for most monitors) Once this is set you should be able to change to the resolution you want along with full screen.

Brusana's Avatar


Brusana
12.14.2011 , 01:44 AM | #5
My monitors refresh rate is only 56 Hz, I'm able to get it in windowed mode but it is still not letting me change the resolution since the screen goes black for longer than that stupid timer is there.

Edit: Well I'm able to manually scale the windowed mode and that's giving me alot better fps, but I'd rather have it set to a lower resolution and have it full screen.

kylezo's Avatar


kylezo
12.14.2011 , 02:17 AM | #6
Quote: Originally Posted by brusana View Post
edit: Well i'm able to manually scale the windowed mode and that's giving me alot better fps, but i'd rather have it set to a lower resolution and have it full screen.
+1 +1 +1 +1 +1 +1 +1 +1 +

AriTrk's Avatar


AriTrk
12.14.2011 , 02:29 AM | #7
press start
type to search field
%appdata%
move one level up to APPdata
then LOCAL
find the folder named SWTOR> BetaTest > Settings
so for quick location
C:\Users\XXXinsert ur comp nameXXX\AppData\Local\SWTOR\betatest\settings


locate the client_settings.ini and open it to change for your desired resolution

i didnt get an EGA so dunno if anything changed since last beta so it may not work if they did smt about .ini files


[Renderer]
D3DFullScreen = true
Height = 1050
NativeHeight = 1050
NativeWidth = 1680
Width = 1680
WindowX = 0
WindowY = 0
EnableBloom = false
TextureQuality = 1
UseMinSpecShaders = true
DynamicLightsLimit = 0
doShadows = false
PlantDensity = 0
AllowDepthOfField = false
VerticalSyncState = false
FarClipScale = 0.25

Brusana's Avatar


Brusana
12.14.2011 , 11:12 AM | #8
This worked except I had to go to C:\Users\XXXinsert ur comp nameXXX\AppData\Local\SWTOR\swtor\settings but other than that it worked perfectly! Thank you very much.

Karness's Avatar


Karness
12.14.2011 , 11:40 AM | #9
Worked for me! thanks, now sticky this so everyone will know!
/VIP MODE ON

Carlossus's Avatar


Carlossus
12.16.2011 , 02:27 PM | #10
AriTrk - Thanks so much! worked a charm!

I was having trouble with not being able to run fullscreen, I managed certain resolutions in beta just fine, but trying fullscreen in EGA was a no go for some reason.

I edited the file you pointed me at, only things I changed were - d3drenderer fullscreen to 'true', fullscreen to 'true' and set my native resolutions to match the resolutions (they were different) and hey presto, I now have fullscreen gaming glory!

Cheers again!