Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Play button doesn't work *solved*

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Play button doesn't work *solved*

RockyLad's Avatar

12.16.2011 , 01:15 PM | #1
Hi guys,

Just got my EGA invite a couple of hours ago.

But when try to start the game I get stuck.

I put my email and password in, then on the next screen I hear a noise and the play button is lit. But when I click on it it de-luminates and nothing happens.

Anyone got any ideas?


RockyLad's Avatar

12.16.2011 , 01:20 PM | #2
Onto the 3rd page already


Kashmina's Avatar

12.16.2011 , 01:21 PM | #3
Did you accept your Eula and TOS?
-( Ori'vod - Beskar - #1066 )-
| Sanctum of the Exalted | PvP/PvE/RP Playstyles | Social |
Website | Forum | Join Beskar | Video
Est. 2008. All Empire classes welcome. Mandalorian-themed.

RockyLad's Avatar

12.16.2011 , 01:22 PM | #4
Quote: Originally Posted by Kashmina View Post
Did you accept your Eula and TOS?
I dont see any T&C

RockyLad's Avatar

12.16.2011 , 01:37 PM | #5
Turns out it was my firewall.....rookie mistake.

DzokISVK's Avatar

12.16.2011 , 01:39 PM | #6
Have Early Acces ?
Have subscription completed?

If yes, support will better help you
"Meditate on this, I will."