Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Node SpecCache - unable to open NodeSpecCache for writing

STAR WARS: The Old Republic > English > Customer Service
Node SpecCache - unable to open NodeSpecCache for writing
First BioWare Post First BioWare Post

Packetdancer's Avatar


Packetdancer
12.14.2011 , 03:23 PM | #11
The most common cause of this seems to be having a language other than English (United States) set as the fallback language in your Windows preferences. If you're running Windows 7, this can be set from the 'Region and Language' control panel; go to the Administrative tab and make sure the 'Current language for non-Unicode programs' is set as 'English (United States)' -- if that's not the setting, change it and try running again.

When you create a new user, that setting's probably reverting to the default, which is what's causing it to work on a secondary user.
Pahke Stardancer (Jedi Sentinel, Save Taris) / Random CS Forum Participant
Writer, photographer, software engineer, GAMER.


docTOR: SWTOR Launcher Troubleshooting Guide

Sadcl's Avatar


Sadcl
12.14.2011 , 04:03 PM | #12
This advice is good, but don't get me wrong - its only "time" advice. We payed for game and we want good quality from it, which doesn't mean that we must create more users on our PC to play it properly.
I can understand problems with qeues and lags and even small ingame bugs, but this...Error 6 was one of the eldest errors and this new error ("NodeSpecCache - unable open NodeSpecCache for writing") is almost equal to Error 6...and still we don't have any proper answer from Bioware when they gonna fix it...if they gonna fix it at all, ofc.
This isn't the best game-start-impression imo.

AnnieSamonova's Avatar


AnnieSamonova
12.15.2011 , 12:38 PM | #13
Packetdancer, It doesn't work

Bal_Sagoth's Avatar


Bal_Sagoth
12.15.2011 , 01:22 PM | #14
Quote: Originally Posted by Packetdancer View Post
The most common cause of this seems to be having a language other than English (United States) set as the fallback language in your Windows preferences. If you're running Windows 7, this can be set from the 'Region and Language' control panel; go to the Administrative tab and make sure the 'Current language for non-Unicode programs' is set as 'English (United States)' -- if that's not the setting, change it and try running again.

When you create a new user, that setting's probably reverting to the default, which is what's causing it to work on a secondary user.
Tnx Packetdancer, it worked for me, im in game it looks gorgeous
Really annoying to have to switch languages all the time
Bioware pls look into this
per aspera ad astra

Vagelis's Avatar


Vagelis
12.16.2011 , 01:59 AM | #15
Yes, they must look into this because its very annoying to change the language and restart your pc every time you want to play the game. There are other programs (not SWTOR) that stop running if you change the language after you have intall them...so when you stop playing you must change the language agen to run them. I hope they will change that soon

Bal_Sagoth's Avatar


Bal_Sagoth
12.16.2011 , 10:46 AM | #16
Quote: Originally Posted by Vagelis View Post
Yes, they must look into this because its very annoying to change the language and restart your pc every time you want to play the game. There are other programs (not SWTOR) that stop running if you change the language after you have intall them...so when you stop playing you must change the language agen to run them. I hope they will change that soon
Just create a 2nd User in Win7 profiles and switch when you want to play SW:ToR, must faster
Kalh Tyxh Vaggo
per aspera ad astra

SirRobin's Avatar


SirRobin
12.16.2011 , 10:58 AM | #17
Are you in the US? My default language is already english and I'm running XP, not Win7. Oddly enough in my google searches, ty BW for removing search on your own forum, I don't see anyone reporting this error that uses Vista. I've gotten this error at random since Beta and I've never seen BioWare respond with anything besides uninstall and reinstall. Which I've never heard of actually fixing it. For me it happens when clicking on select in the character screen or when loading a planet.

Very annoying and it happened four times in a row this morning before I gave up and started looking again for a fix or workaround.

SirRobin's Avatar


SirRobin
12.16.2011 , 11:07 AM | #18
Should mention that when this error starts happening, my chances of getting in-game again improve if I restart my PC. Doesn't always work but it does appear to help.

SithKedi's Avatar


SithKedi
12.16.2011 , 11:18 AM | #19
Thx,I will try after reinstalling SWTOR