Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Annoying Fps Drop in High end Pc

STAR WARS: The Old Republic > English > Customer Service
Annoying Fps Drop in High end Pc

Xaegant's Avatar


Xaegant
03.30.2012 , 11:06 AM | #1
Hi to all Republic and Imperial!

My problem is I'm getting very low fps 25-30 in Republic Fleet, In Warzone my fps drop from 90 to 50 to lowest is 29fps. While riding unmounting speeder my fps drop to 30 from 90fps, also it feel sluggish when exting some buildings. I update my Nvidia video card to latest Driver 296.10 WHQL. Here is the list of my spec:

Spoiler

XiZZu's Avatar


XiZZu
03.30.2012 , 11:40 AM | #2
Only 8 core cpu????? you need a 256 core cpu to run swtor at 60 fps. Jokes aside at first glance your system shouldnt be under 60 fps in wz. That said the engine is being optimed in the next patch (should be around in 2 - 4 weeks).

gullfisk's Avatar


gullfisk
03.30.2012 , 12:00 PM | #3
Quote: Originally Posted by XiZZu View Post
Only 8 core cpu????? you need a 256 core cpu to run swtor at 60 fps. Jokes aside at first glance your system shouldnt be under 60 fps in wz. That said the engine is being optimed in the next patch (should be around in 2 - 4 weeks).
Its not 8 CPUs.

Its a hyperthreaded quadcore.

But yeah, that pc should have no problem with this game.

I have the same processor @ 4700 mhz and a gtx 590 and 32 gig ram, and i get fps drops too. Drops down to around 30 on fleet, with everything on low.

Well, im not really bothered by it anymore, since i have cancelled my account.