Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Crashes after pressing play

STAR WARS: The Old Republic > English > Customer Service
Crashes after pressing play
First BioWare Post First BioWare Post

Katzchenn's Avatar


Katzchenn
03.29.2012 , 11:22 PM | #1
Hi,

I think I'm having an issue a few other people are having. I can access the launcher just fine but when I click play it goes to black screen for a second as if it's about to load then crashes right back to my desktop. I've updated my .net framework, checked the firewall exception include SWTOR and checked for updates for stuff like Java, run the repair tool on my launcher once which did nothing and am running it again currently. Every time I try to use the fixlauncher it starts and the exits a second later with no message. I've since had no luck with running the repair service, have tried renaming my launcher and doing that thing they suggest with that, but could find the update file, and have deleted the patch file which was suggested in another thread similar to mine. I'm not sure what else to do since I've tried most of the other things... Help please?

Beesodd's Avatar


Beesodd
03.29.2012 , 11:59 PM | #2 This is the last staff post in this thread.  
Greetings Katzchenn,

Have you tried running the installer over your existing install? Have you been able to play the game before?

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Katzchenn's Avatar


Katzchenn
03.30.2012 , 12:09 AM | #3
I have been able to play the game before, this is actually the second time it's happened to me, sorry should have mentioned that. The first time I fixed it by re-installing the game entirely, which takes a bit, and thought it was fixed, but apparently not. it seems to happen after i play for a bit, exit, then come back to the game later.
I'm re-downloading the main assets file now?