Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

"Cure the Jedi Master" quest line in Tatooine is buggy

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
"Cure the Jedi Master" quest line in Tatooine is buggy

TaiBrix's Avatar

03.29.2012 , 08:08 PM | #1
"The Ultimate Warroirs" After curing the jedi master on Tatooine I go to the ship to access the holocom terminal and the screen freezes. Tried several options to fix the situation - logged out and back - shut down the computer - tried it on husbands computer - reset the mission and did it solo (first time around was teamed with husband) - all the same results - the cut sceen freezes. This does not lock up my computer - I can only close the program from the taskbar. I could always get into the game with this toon and play other Tatooine missions - just could not get the one mission to complete.

I have noticed a pattern of the consular's missions being buggy on Tatooine. I had the reset the first mission on arriving at the planet, cannot at this point remember why, the mission "looking out for the little guy" where you have to kill war droids did not work teamed up - only in solo mode and now the end class mission (Ultimate Warriors) has its problems.

I tried changing the window settings- resolution settings - to no avail. Tried clicking on the holocom outside Tatooine planet and the space station - no change. I finally decided to go to alderaan - the next stop in the class missions and an interesting outcome. Upon arrival I got a cut scene that basically welcomed me to the planet and set up the next mission in the class line. Once that interaction finished - I clicked on the holocom and the missing conversation started. I was able to complete the last Tatooine mission and receive the reward. So the start of the next mission triggered the end of the last mission - but only because I had traveled to Alderaan.

None of this really makes any sense - but the consular missions are a little buggy in Tatooine.

I reported this in game and a couple of people tried to help - finally got arround it myself but the missions need to be de-bugged.

Zogbert's Avatar

03.29.2012 , 10:47 PM | #2
See my thread.

Tween my wife and my accounts, we have 4 toons that cannot proceed with their class quests.

Get ready to be ignored.