Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Lag spikes

First BioWare Post First BioWare Post

hulkweazel's Avatar


hulkweazel
03.23.2012 , 11:46 PM | #1
Every once in a while, I would get extremely bad lag spikes ranging between 1000-5000ms latency that just makes the game impossible to play for about a minute. After this, it goes back to normal, but it is a serious problem if I'm in a warzone or FP.

It could be my internet connection, but I doubt it considering I don't have problems with any other game. Is there anything I can do about this?

Sutii's Avatar


Sutii
03.24.2012 , 12:48 AM | #2 This is the last staff post in this thread.  
Hello hulkweazel,

I know you have probably already done some of the steps, however could I ask you to run through our Connection Issues thread and ensure that you have done each of them.

Could you also remove and re-add the Launcher (launcher.exe) and Client (swtor.exe) to communicate through your firewall.

Finally, you should try using the 'Repair' utility on the launcher. To do this please click on the button located in the bottom left hand corner of the launcher window after you have logged into it, but before you click 'Play'. This will open a settings menu where you will be able to find and click on the 'Repair' button.

Please let the repair function do its work. Although a message may imply that it downloads a considerable amount of data, this is not accurate as it will only download a small proportion of it in order to repair your existing files.

Please let us know how you get on.
Sutii | BioWare Customer Service - Forum Support

hulkweazel's Avatar


hulkweazel
03.25.2012 , 01:14 PM | #3
I tried the repair function, so far there have been virtually no lag spikes and the rare occasions there are it's a LOT more manageable as it peaks around 1000ms now. Thanks.