Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Fix false emperor


Candrimon's Avatar


Candrimon
03.13.2012 , 10:46 PM | #31
We had several bugs show up in FE tonight.

We had one trash pull with 2 droids (cc'd by JK and Gunslinger) and several other mobs where the tank jumped in and couldn't hit any of the mobs, the healer had LOS issues on the tank, so he died. Healer BR the tank, and everything started evading.

We had several occasions where we didn't get out of combat until about 10 seconds after the last mob died in the group we were fighting.

We also had big trouble on Malgus. Once he reset on us in the middle of the fight. Several times, he started using unlimited power at about 35-45%, long before we were thinking about moving him to be ready to punt him. We never had him go 1-1 with all 4 of us before he used the unlimited power. Time constraints kept us from continuing to try. Maybe the kiting trick would work now, but if he's going berserk at 40%, that's a BIG change, undocumented.

NotRonin's Avatar


NotRonin
03.13.2012 , 11:16 PM | #32
Malgus will start using unlimited power from around 50% health, and somtimes more than once. It must be interrupted. Make sure you don't kite Malgus too far away during the 'solo' phase., otherwise he can use unlimited power in a place that is out of reach.

SmallDarthToe's Avatar


SmallDarthToe
03.14.2012 , 12:03 AM | #33
just spent an hour wiping on malgus. hes not fixed, and we werent doing it wrong. its bugged. ive done it the exact way we tried doing it quite a few times. our strategy is solid, the bugs just suck. grenades and knockbacks were completely useless. i cant say whether or not its less bugged for the repubs. all i know is it may not always bug, but it does bug enough to merit some attention.

zlahham's Avatar


zlahham
03.15.2012 , 08:43 PM | #34
Yesterday I was doing FE HM. When we got to Malgus all was well up until the part came when we had to knock him out, suddenly the whole thing glitches, me and another guy are reset outside the instance and we couldn't get back in.
And guess what dropped... the Jedi Knight headpiece that i have been waiting for ages to get. I tried countless times to get back in, we were just locked, missing my headpiece and my quest. Thank you BioWare for not being cooperative in this matter.
They just replied that this matter has been sent to the development team, and they wouldnt restore my headpiece...
Hanibal | Jedi Guardian
Spark of Insanity | EU The Red Eclipse

BroadStreetBully's Avatar


BroadStreetBully
03.16.2012 , 11:04 AM | #35
You mean chestpiece right? Because Malgus drops the Columi chest not head.

NotDonnaReed's Avatar


NotDonnaReed
03.17.2012 , 12:32 AM | #36
My guild has cleared False Emperor HM several times (Republic side), and we've only noticed one bug on one boss in all those times. (Tonight Malgus managed to rescue himself from the pit after we blew him over; it was bizarre.)

I don't think this flashpoint is buggy on a regular basis. The first boss (Kregg) should never be tanked on the bridge. You bring him over to the area in front of the bridge and spread the party out in a square so they don't all get whacked by the spinning cleave. The next boss (Jindo) is all about timing. You have to use the console at the right time or it glitches the encounter. The HK boss is all about breaking him out of stealth TWICE so he doesn't one-shot someone. Malgus is dead easy if you tank him with your back to the side of the staircase. He can't knock you anywhere, and he's easily contained for interrupting Unlimited Power. The only thing you have to be careful of really is not DPSing him below 15 percent when the party is about to go into stasis, as you can't position him effectively below 10 percent health.

I really don't think there's anything wrong with this encounter that can't be solved by a minor change in tactics.

Colow_Leper's Avatar


Colow_Leper
03.21.2012 , 10:39 PM | #37
Right - I notice that there have been no further posts in this particular thread (although I am aware that there may well be several others...)

Tonight we ran FE again - the last few times we have had all kinds of bugs apear in it.

Tonight the instance ran perfectly!

I can't say for certain (obviously) that it is truely fixed - but (fingers crossed) it seems that they have managed to fix this one.

So - well done!
Didn't we just leave this party?