Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Extremely Low FPS on Asus G73jh-A1

STAR WARS: The Old Republic > English > Customer Service
Extremely Low FPS on Asus G73jh-A1
First BioWare Post First BioWare Post

Sylvarius's Avatar


Sylvarius
03.05.2012 , 02:22 PM | #1
Hello, I have an Asus G73jh-a1 gaming laptop with the following specs.

i7 Q 720 @ 1.60 GHz
8 GB RAM
ATI Mobility Radeon HD 5870 1g DDR5
Windows 7 Home Premium 64 bit

I am getting between 10-20 fps in fleet with spikes around 30, and 20-30 in WZ with spikes around 40. I have tried my connection directly and wireless without any difference. This is after doing a system restore to factory defaults and updating my bios to the latest version. I also installed directx 9.0c. I had read that there is a possible connection between bad FPS and mobile video cards... That is intolerable if true.

I have talked to ASUS and they have helped me as much as possible from their end. I can play any game on the market at full settings flawlessly.

I realize there are threads on this already, I was hoping that by posting it separate that an admin would be forced to move it and possibly address the issue.

DXDIAG
Spoiler

Kindajenin's Avatar


Kindajenin
03.05.2012 , 02:25 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Sylvarius,

I would advise you to upgrade your operating system and also ensure that your java, C++ and mircosoft .net framework is fully up to date to enable you to run the game correctly.

If you can please follow the steps outlined:
  1. Typing 'windows update' in search/run box.
  2. Select 'check for updates'.
  3. Then select 'check online for updates from Mircosoft update'.
  4. Install at least all important updates.

I hope this helps you resolve the issues you have been having.
Kindajenin| BioWare Customer Service Forum Support

Sylvarius's Avatar


Sylvarius
03.05.2012 , 02:28 PM | #3
Oh I do realize I am missing SP2 and other updates, I am in the middle of my second system restore, I had already fully updated windows and was still getting bad FPS. That DxDiag i just took while updating, I apologize. I can post an updated one afterwards.

I have also tried forcing settings through Catalyst Control Center, by either forcing a profile or just leaving all of the settings for the application to set the profile, neither helped.

I also have disabled windows aero as suggested in another thread.

andiegirl's Avatar


andiegirl
03.05.2012 , 02:57 PM | #4
Quote: Originally Posted by Kindajenin View Post
ensure that your java,is fully up to date to enable you to run the game correctly.
Java? what do we need java for, doesnt say you need java to run the game.

Sylvarius's Avatar


Sylvarius
03.05.2012 , 03:07 PM | #5
I just updated java anyways.

I am awaiting your reply Kindajenin

Kindajenin's Avatar


Kindajenin
03.05.2012 , 03:30 PM | #6 Click here to go to the next staff post in this thread. Next  
Greetings Sylvarius,

I have seen players in the past who upgraded to service pack 1 for windows 7.

After they restarted they saw an improvement in their FPS issue.

Have you everything up today and preformed a restart?
Kindajenin| BioWare Customer Service Forum Support

renegadeimp's Avatar


renegadeimp
03.05.2012 , 03:33 PM | #7
Quote: Originally Posted by andiegirl View Post
Java? what do we need java for, doesnt say you need java to run the game.
The game uses some of the java runtimes for the launcher and a few game files.
Streamline - A guide to speeding up low - mid range Computer systems.
Latency Thread - Latency issue gathering thread..
Have a tech issue you need help with? You can nomally find me on the Customer Support forum.

Sylvarius's Avatar


Sylvarius
03.05.2012 , 03:38 PM | #8
I have everything up to date and am still seeing FPS problems

Kindajenin's Avatar


Kindajenin
03.05.2012 , 03:40 PM | #9 Click here to go to the next staff post in this thread. Next  
Quote: Originally Posted by Sylvarius View Post
I have everything up to date and am still seeing FPS problems
Greetings Sylvarius,

Can you post your DxDiag again and we can have a look to see if there is anything else we can improve on?
Kindajenin| BioWare Customer Service Forum Support

Sylvarius's Avatar


Sylvarius
03.05.2012 , 07:08 PM | #10
My apologies for the slow response.

Spoiler