Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Black screen when entering game? HELP!

STAR WARS: The Old Republic > English > Customer Service
Black screen when entering game? HELP!

Namyralers's Avatar


Namyralers
12.15.2011 , 11:29 AM | #1
Hello, i just got invited but when i enter the game, its black screen, i can see my mouse, i can move it, i hear the noises it makes when i hover over something, i am in the game but it wont display it, just a black screen. Has this happened to anyone else? And if so, how did you fix it? Please help i am really anxious to play!

Shyanne's Avatar


Shyanne
12.15.2011 , 11:43 AM | #2
I have the same issue. I hit escape and it takes me to the game, but I can't see any of the cinematics. I have a fairly new gaming system and a good video card. I have already updated the drivers but still get the black screen.

Namyralers's Avatar


Namyralers
12.15.2011 , 11:46 AM | #3
I cant see anything, its all black, cinematics or character screen, nothing.

Ballmung's Avatar


Ballmung
12.15.2011 , 11:48 AM | #4
I am having the same problem, and I had this problem during the beta weekend. They still havent fixed this its ridiculous

Illindorn's Avatar


Illindorn
12.15.2011 , 11:49 AM | #5
Also got same issue.


Found this hope it helps

http://www.swtor.com/community/showthread.php?t=3396

Namyralers's Avatar


Namyralers
12.15.2011 , 12:14 PM | #6
I did never let it just be for itself.. Well guess i will do that, did re-download the game and its in the middle of updating, i hoped that would fix, but i guess i will try that. Thanks.

LostLogics's Avatar


LostLogics
12.15.2011 , 12:21 PM | #7
I bet the lot of you are ATI users?

If that is the case you need to update your video card drivers.
See this thread on Guru3D and select the appropriate driver, download, install and try again.
http://forums.guru3d.com/showthread.php?t=355638

Worked like a charm for me.

Namyralers's Avatar


Namyralers
12.15.2011 , 12:35 PM | #8
Well lets hope it works like a charm for me too! When i am done updating n all i will tell you if it worked or not.

Emohawk's Avatar


Emohawk
12.15.2011 , 03:11 PM | #9
Have the same issue

Funkztar's Avatar


Funkztar
12.15.2011 , 03:59 PM | #10
Quote: Originally Posted by Namyralers View Post
I did never let it just be for itself.. Well guess i will do that, did re-download the game and its in the middle of updating, i hoped that would fix, but i guess i will try that. Thanks.
I reinstalled it to..but it didnt work for me :-(
But this helped

http://www.swtor.com/community/showthread.php?t=3396

GL
/Funkztar