Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Bug with displaying cooldowns properly

STAR WARS: The Old Republic > English > Customer Service
Bug with displaying cooldowns properly
First BioWare Post First BioWare Post

Duckling's Avatar


Duckling
02.26.2012 , 05:15 PM | #1
I didn't notice this in the sticky list and after already creating a ticket that just vanished without any reply, I'm posting this here.

I have had a bug on my cooldowns since I started the game. The problem is that sometime (pretty much every fight, but not all the time) cooldowns on my actionbar are displayed wrongly. In other words a skill is marked as it has a cd, even if it's ready to use. I can see the "shroud" falling on the skill icon and if I hoover my mouse over the skill, the ability window displays the time remaining with the cooldown.

I find it a bit odd, this hasn't been fixed or is it even noticed? Very frustrating that you have to remember which skills are usable and which are not, because you cannot trust the feedback you get.

And before someone suggests it -no. It's not a global cooldown I'm seeing, but an actual bug.

Gatzoh's Avatar


Gatzoh
02.26.2012 , 07:41 PM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Duckling,

I think you discribe the current situation that the cooldown text is sometimes displayed as if it is stuck. Please be assured that this will be fixed soon in an upcoming patch. Meanwhile you can use "CTRL" + 2x "U" to reset the interface and displayed text.
Gatzoh | BioWare Customer Service - Forum Support

Duckling's Avatar


Duckling
02.27.2012 , 02:41 AM | #3
Quote: Originally Posted by Gatzoh View Post
Greetings Duckling,

I think you discribe the current situation that the cooldown text is sometimes displayed as if it is stuck. Please be assured that this will be fixed soon in an upcoming patch. Meanwhile you can use "CTRL" + 2x "U" to reset the interface and displayed text.
I don't think we are talking about the same thing. The problem is that my skills in my action bars are marked having a cooldown even they actually are ready to use. This happens all the time. In every fight. I can't reset my UI multiple times per fight.

I think it has something to do with using skills from different action bar sheets. I only have one action bar on my screen and switch to next/previous one by my mouse buttons. Usually problem occures, when I've used some skill in action bar 2 and then change the view back to action bar 1. Suddenly one or more of my skills in action bar 1 shows cooldown they don't actually have.

They are not "stuck" in any way, they just show a cooldown when they are not supposed to. The cd animation works properly, there is that ready-flash and everything if I wait the counter to finish. If I use the skill before the cd counter is finished, the skill is used properly and cd resets once again.

Brellon's Avatar


Brellon
02.27.2012 , 02:54 AM | #4 Click here to go to the next staff post in this thread. Next  
Thanks for clarifying this!

If you haven't already, we would like to ask you to send in a bug report.

As Gatzoh already mentioned, we are working on a fix for the Cooldown display and hope that it fixes your display as well.
Brellon | BioWare Customer Service - Forum Support

Duckling's Avatar


Duckling
02.27.2012 , 03:10 AM | #5
I submitted a ticket earlier, but it just vanished without any reply, so I put it here too. I'm glad if it's received and acknowledged.

As I have had some troubles to explain the matter, I'm writing another example of the problem:

I just logged in and tried some of my skills. When I activate my Jet Boost (located in action bar 2, slot 2) my Missile Blast (located in action bar 1, slot 2) goes to 30s cd. The missile Blast is an instant skill, which don't even have a cd! So for some reason Jet Boost's cd (which is that 30s) shows also on Missile Blast. I can reproduce this example as many times as I want to.
If I again switch my view to another action bar and come back, the Missile Blast doesn't have cd on it anymore. So it lasts that 30s if I keep watching it, but if I "refresh" the action bar, the problem fixes itself.

Maybe we were talking about the same thing after all and this can be described as "stuck".



<one more addition>
I think I know what causes this now. If I activate a skill in action bar X and switch to another action bar BEFORE the global cooldown is finished, UI messes things up and the same slot in different action bar shows cooldown wrongly. I tried to wait the global cooldown to end before changing to my bar 1 and Missile Blast didn't have a cd on it.
I'm sending another ticket on this and describe the problem more accurate.

Gatzoh's Avatar


Gatzoh
02.27.2012 , 03:44 PM | #6 This is the last staff post in this thread.  
Greetings again Duckling,

you should have received an E-Mail today in the morning, telling your report has been forwarded to the special department which will check this issue. You are welcome to send additional information regarding your ticket as this may help to resolve the issue.
Gatzoh | BioWare Customer Service - Forum Support

BelphagorAD's Avatar


BelphagorAD
02.27.2012 , 04:00 PM | #7
I am having this happen as well. I don't recall exactly which cooldown settings I chose, but I think it is 1 & 2- I will have to verify that.

The skill is still 'lit' but has the cooldown time on the icon.

I tried to figure out what the trigger was before submitting a bug report, but it was happening on some (not all) conversations when I went into the conversation with a cooldown currently ticking down. Some would hang, others would not- so I'm not 100% sure what was doing it.

It's not a terrible bug because you can still use them, the problem is just visual. (if only looking for lit), but if only glancing to see if there is time left- I got to thinking, this has to be ready by now... oh wait- the timer is stopped. (or still displaying the time that I went into the conversation at)
RP-Rubat Crystal [Empire]- LL 21
Harkim [50op] 400AS, En'vi [50mc] 400CY, Dae. [50so] 400BE, Wak. [21jg]
RP-The Ebon Hawk [Republic]- LL 17
Nic.[50sg] 400SW, Zen.[50sn] 400AF, Tal. [30sh], Cuin [25vg], Yav.[17gs]

BrianAC's Avatar


BrianAC
03.07.2013 , 02:33 AM | #8
https://mail-attachment.googleuserco...sHjzQ&sadssc=1


I am still having an issue with something in the game. i will show you a picture of what i am experiencing... Notice that the cool downs are showing 8 hours, for all of them, and on the right you see the exact time, 8h, 44m and 35s (time i took the picture from my phone) Its not showing the real cool down timers for any of the keys. But when the actual time is up it disappears For example, Unnatural Might is a 6 sec cool down for me, but when i use it, it shows the time in the picture above, but after 6 seconds, the time above in the picture will disappear. The white bar that slides down the box of the attack i am using does not show, just the 8h like above. This doesnt happen all the time, Sometimes i will log on and everything will be working ok, and other times i log on this will be happening, This has been happening more often lately, and sometimes i cant get it to work right unless i log off the game and log back in at least 3 times, sometimes it takes me like 5 or more times of logging in and back out. I have tried multiple things, like uninstalling the game and reinstalling it using the discs, and reinstalling it using the option from the the site. I have ran the repair option plenty of times, neither of these have completely resolved this issue here. I am hopping there is an answer to why this is happening and that it will be taken care of ASAP, when this happens it does not make the game fun to play because im taking a lot of time to sign off and back in multiple times, sometimes at least 5 times in a row. When i am in groups like FP's or Ops and this happens, i have to worry about losing the group i am with because i have to sign off and back in multiple times, or that they will get tired of waiting and kick me and look for someone else to take my spot. It is really frustrating dealing with this all the time. I hope to get a reply to this soon and see what can be done to resolve this issue