Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Trouble with Story Quest Mind Trap?

STAR WARS: The Old Republic > English > Classes
Trouble with Story Quest Mind Trap?

Mikkeos's Avatar


Mikkeos
01.30.2012 , 04:18 AM | #11
Quote: Originally Posted by KeeLoBash View Post
I'm stuck on this same quest, but at a later point on it. I can't get innoculated to get onto Quesh to talk to the Administrator because it says I have to complete other quests before I can continue, which it also says at virtually all other relevant locations (such as Kaliyo wanting to talk to me on my ship). I guess I'll try resetting the quest with ctrl+U.
This usually happens when your quest log is full.
Q: So, is there anything at all in the game that mitigates falling damage?
A: elevators

Skraven-FP's Avatar


Skraven-FP
01.30.2012 , 11:57 AM | #12
[QUOTE=Invious;1004102]Any time a quest says go to Dromund Kaas, you have to actually take your ship to Dromund Kaas. Taking a shuttle from the space station doesn't do it, even though on your map in Dromund Kaas it tells you to go there, you have to actually fly there in your ship to complete that step of the quest.[/QUOTE]I

I did exactly what Tac_Obray suggests and confirm this workaround actually works. Just make sure you fly to Dromund Kass from your SHIP and not the Imperila Fleet. I had the same issue with the questline being bugged so I tried the suggestion here on the forum post and it works. Now I can continue the questline to Quesh with no hitch.

sparkbibo's Avatar


sparkbibo
02.06.2012 , 08:45 PM | #13
I also have this problem. I tried the workaround... to fly somewhere and then return to Drumand Kaas via my own ship. Still does not work.

Here's how it went down:

I finished up Taris, the planet quest line and the Agent quest line. Went to my ship to see what was up. Had a trippy experience when Watcher X visits my dreams and tells me to go to Drumand Kaas to look in the files.

However, I went back down to Taris to do the Bonus quest line. When I finished that, I went via my ship to Drumand Kaas as directed. Nothing is lit up in on the map and I can't do anything at Imperial Intelligence HQ.

I tried the workaround went all the way to Taris, stepped foot on the planet even, and then flew back to DK. No go.

Meesa Sad.