Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Forgotten my Security question!!


LiamC's Avatar

12.13.2011 , 09:23 AM | #11
Quote: Originally Posted by Kitty_Whoopass View Post
I had this problem - I'd mistyped one of my answers. I had to call to get it fixed. Tried three times. The first two times I was on hold for over an hour and hung up. The third time I called late at night on a Sunday (west coast US) and got through in less than 20 minutes.

It is frustrating! I would open a ticket via the website if you can't afford to call. I would guess response times will be slower now because everyone is trying to get in all at once.
As long as I can get help through Tickets I don't mind, My internet keeps cutting out ever 5 mins, So wouldn't be able to play anyways, I Just want my account sorted out of now.
Proud Non CE Owner.
Neptune, PVP, Republic guild.

Rahl_Windsong's Avatar

12.13.2011 , 09:25 AM | #12
No, I did not have to phone them. I started to have this issue last friday when I wanted to reinstall the client. When I tried to log in it asked me "What is your favorite activity?" and obviously I got the answer wrong and it locked my account. So I emailed them and they requested that I send them a scan of my drivers license, or government ID, or a passport. I emailed them my drivers license however I still have not heard anything back about that, though they did say that if I provided them with the correct ID that they would then fix my problem.

So I think with the launch happening that they put my request on the back burner. So hearing nothing back from them yet, I decided to see if I could get into my account and edit my answers, and I had already thought of the number idea long before this so in the future there is no mistake.

Like I said, once I got into my account when I clicked on "Edit Security Questions" I think it asked me every single question I had on file (5 of them) and I must have got them right because finally I got to the edit screen and now I have no security question issues.

Raan's Avatar

12.13.2011 , 09:33 AM | #13
I had this same problem, couldn't remember the stupid question. Tried to call their customer support and all I got was "At this time all customer support agents are busy please call later". I redialed over and over for 10 minutes until I finally got into a phone queue.

I went through every option and finally found one to speak to a person. While on the extremely long hold time I decided to try and reset my password on the website and it let me.
I still can't change the answers to my security questions even though I've logged into my account on the website.

The 855 number you call is very frustrating and seems to be located somewhere in the UK. Overall I've given the game 8-9 rating but this part of customer service gets a 3-4.

Oh and entering multiple tickets through the email system is a dead end. All you get is the response listed below. All this prior to when the early access was released. I hate to see the phone queue now.

Customer Phone support..... FAIL

Email response
"We apologize for the inconveniance that it had caused, because there are huge volume of calls and long queue on the phone support line. Please bear with us for this is the only option for now in fresolving security account questions.?

dumbpeople's Avatar

12.13.2011 , 09:48 AM | #14
The customer support doesn't even deserve a 3 or a 4... it's a ONE AT BEST.

First... the security questions coming up all the time are a joke. Second... a bigger joke is that you have 5 questions, but you may forget an answer to one... well lucky for me, the one I forgot is the one I got. So you're stuck trying to figure out any possible answer for a question you don't remember. You should have the option to pick from the other 4!

Third... phone support is atrocious!!!!!!!!!!!!!!!!! Before when this happened in November, it took me AGES to get through, so much so that I just gave up. But AT LEAST I GOT TO THE POINT OF BEING ON HOLD! Today, immediately calling support grants you a message stating everyone is too busy, try again later. *** IS THAT?

And before anyone says I have a bad memory, it's obviously not this account that is locked by being unable to answer the SQ!