Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

IS soa still bugged??

tuckwd's Avatar

02.03.2012 , 09:12 AM | #21
the 16 man bugs are much more prevalent than the 8. we had no problems with soa on the 8 and have one shotted him (normal).

last night we experienced these:

1. green goo spawns and is not visible until you are pretty much dead due to the slowing unless a healer can rescue you.

2. orbs constantly spawn and must be blown up by a tank or someone that is bubbled by a sage. if this is part of the mechanic, then it *********** sucks. it is not like this in 8 man.

3. orbs tend to disappear. after you either blow them up or kite them until they despawn which they rarely do, they will disappear and come back up to blow you up for an instant kill.

4. floors were not spawning back -- had to reset instance.

5. constantly being thrown into combat after wipe and no one has attacked or got near him.

6. pylons were dropped straight on him and doing nothing but hurting the tank.

there also needs to an addition to being able to SEE the pylons. very hard to see the pylon with messing with your camera angles right away. this doesn't help when you are also being chased by orbs and stuff. i feel sorry for the tanks in the soa fight.

also..16 man aoe healing blows. we had 4 healers 3 sages and one commando medic and when 3 of us throw our aoes at the same time only 2 of the groups get healed. my group was not being healed although they were in both other casters aoe including mine.

so after attempting 16 man normal several times and it being very bug heavy i am saying screw 16 mans and i'll stick to 8 mans.

Annexium's Avatar

02.03.2012 , 12:05 PM | #22
Quote: Originally Posted by LordZanos View Post
At least every time you wipe you get to listen to his intro monologue.
Korriban korriban korriban, korriban was korriban until korriban korriban korriban!

Trulee's Avatar

02.03.2012 , 12:37 PM | #23
Quote: Originally Posted by JahDux View Post
So Soa isnt bugged, except it is bugged.

Im confused.

Btw, me and my guild went EV normal mode for our first ops run, did 4/5 progress until Soa, only to find every single problem mentioned above.

Im also disapoint .
Same for us as far as the bugs were concerned. We seem to always have the bad luck of either being locked out of the instance or the boss bugging. SOA despawns at 5%. We could not loot from the Ancient Pylon chest either.