Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

BioWare/Origin Preorder code F-up

STAR WARS: The Old Republic > English > Customer Service
BioWare/Origin Preorder code F-up

Rioziel's Avatar


Rioziel
12.14.2011 , 11:22 PM | #1
I preordered the game aroun Dec. 8th.

Entered my preorder code.

I go to my swtor account > code redemption history, there is no preorder code.

I attempt to re-sumbit the code.

This code has already been used.



Fix please.

Rulyen's Avatar


Rulyen
12.14.2011 , 11:24 PM | #2
When you go to 'My Account', then to 'Code Redemption' and scroll down to 'Code History' you should see your already registered pre-order.

The product key will be sent to you by Origin about 16th December.

You also would like to have a look here:

http://www.swtor.com/community/showp...&postcount=499

Thank you.
. Fear teh Beta Pixel!

Rohrnin's Avatar


Rohrnin
12.14.2011 , 11:30 PM | #3
No offense meant here, but people need to read and pay attention to what people are asking on this. My wife has the same problem.

CS said it is a known issue, promised her it would be taken care of, bump her back up to where she is supposed to be in queue... 24 hours later and no emails, no code showing up in My Account, Game, Pre-Order, or otherwise and game is not launchable.

The issue is that:

You purchased your game way back when
You got your *pre-order* code from whoever (Origin, BB, Walmart, etc.)
You entered that into this website
Code showed up just fine.
You even played for a few weekends in Beta
Your guild even got registered with YOU in it
Forums go down
Forums come back up
There is no longer a Pre Order code in you account
If you try to re-enter your code it states it is already in use.

End of list - it is not the same issue as a product registration code misunderstanding or what have you.

The real problem is that CS should not promise people it will be taken care of if they can't take care of it. I realize crap happens, but my wife pre-ordered like 15min after they announced release. Now she is sitting around waiting for an answer they said they were going to send her long before now.

Grf

Rulyen's Avatar


Rulyen
12.14.2011 , 11:32 PM | #4
Quote: Originally Posted by Rohrnin View Post
No offense meant here, but people need to read and pay attention to what people are asking on this. My wife has the same problem.

CS said it is a known issue, promised her it would be taken care of, bump her back up to where she is supposed to be in queue... 24 hours later and no emails, no code showing up in My Account, Game, Pre-Order, or otherwise and game is not launchable.

The issue is that:

You purchased your game way back when
You got your *pre-order* code from whoever (Origin, BB, Walmart, etc.)
You entered that into this website
Code showed up just fine.
You even played for a few weekends in Beta
Your guild even got registered with YOU in it
Forums go down
Forums come back up
There is no longer a Pre Order code in you account
If you try to re-enter your code it states it is already in use.

End of list - it is not the same issue as a product registration code misunderstanding or what have you.

The real problem is that CS should not promise people it will be taken care of if they can't take care of it. I realize crap happens, but my wife pre-ordered like 15min after they announced release. Now she is sitting around waiting for an answer they said they were going to send her long before now.

Grf
My apologies, I'll admit I only skimmed the OP and didn't notice that they were complaining of a once-redeemed, now lost code.
. Fear teh Beta Pixel!

Rohrnin's Avatar


Rohrnin
12.14.2011 , 11:36 PM | #5
No apology necessary - I certainly didn't mean to sound so brash - but the point I was intending to make is I think that CS is also ignoring this issue because they think it has something to do with the post that you and others keep linking to when it is nothing of the sort. Perhaps a related database matter but I would venture it has a completely different aspect to it.

so I guess CS -> READ THESE CAREFULLY!

Darthoctapus's Avatar


Darthoctapus
12.15.2011 , 12:22 AM | #6
Quote: Originally Posted by Rohrnin View Post
No offense meant here, but people need to read and pay attention to what people are asking on this. My wife has the same problem.

CS said it is a known issue, promised her it would be taken care of, bump her back up to where she is supposed to be in queue... 24 hours later and no emails, no code showing up in My Account, Game, Pre-Order, or otherwise and game is not launchable.

The issue is that:

You purchased your game way back when
You got your *pre-order* code from whoever (Origin, BB, Walmart, etc.)
You entered that into this website
Code showed up just fine.
You even played for a few weekends in Beta
Your guild even got registered with YOU in it
Forums go down
Forums come back up
There is no longer a Pre Order code in you account
If you try to re-enter your code it states it is already in use.

End of list - it is not the same issue as a product registration code misunderstanding or what have you.

The real problem is that CS should not promise people it will be taken care of if they can't take care of it. I realize crap happens, but my wife pre-ordered like 15min after they announced release. Now she is sitting around waiting for an answer they said they were going to send her long before now.

Grf

My friend is also having the same issue, i'm really wondering if we will see any response about it.