Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Launcher still doesn't work for me

STAR WARS: The Old Republic > English > Customer Service
Launcher still doesn't work for me

Taerin's Avatar


Taerin
12.14.2011 , 09:10 PM | #1
I had this problem back in beta and it's still around It only occurs on my Windows 7 64-bit desktop. The launcher runs fine on my Vista 64-bit laptop.

When I double click launcher.exe and enter admin credentials, the process just hangs and the launcher never starts. I've already went through the launcher troubleshooting guide and none of it is helpful.

dakotaev's Avatar


dakotaev
12.14.2011 , 09:39 PM | #2
I'm having the same issue. I played in 3 beta weekends and I did not have this problem.

Un-installed and Re-downloaded the installer... Updated all my drivers and windows updates, still can't get it to run.

It launches the exe and it's there in task manager but the launcher just never appears on my screen.

dakotaev's Avatar


dakotaev
12.14.2011 , 10:04 PM | #3
By the way I figured out what the problem was for me.

I use my ISP's proxy server (they do a lot of caching and it improves speeds).

Once I removed the proxy server settings the launcher worked like a dream.

Hoping this info helps someone else out.

Credit goes to this thread for tipping me off to the problem. Thank you Packetdancer.

http://www.swtor.com/community/showthread.php?t=890