Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Just Starting, Help

Darth_Malevolent's Avatar


Darth_Malevolent
12.14.2011 , 09:00 PM | #1
Um, Im playing as Sith Inquisitor, and I started in Korriban, and it almost seems like one environment is ontop of another environment with polys shooting everywhere, blocking my field of vision..... is this just me? Did I mess up the patch some where and get some old crap?
The Dark Side is Omnipotent in this one

Dasyus's Avatar


Dasyus
12.14.2011 , 09:04 PM | #2
First, check to make sure your video card is up to date. If that doesn't work, try adjusting your settings within the game. If Anti-Aliasing is on, turn it off, or lower it. If that doesn't work, then I hope someone else can hop on here and help you.
Yes, I know I am lacking an avatar. It's on purpose.

Darth_Malevolent's Avatar


Darth_Malevolent
12.14.2011 , 09:07 PM | #3
Where would I check to see specs required?
The Dark Side is Omnipotent in this one

Sundragon's Avatar


Sundragon
12.14.2011 , 09:09 PM | #4
Sounds like a heat issue.


To test it, open your computer and put a standard house-fan and blow it right on your graphics card. Then start the game.

If that fixes the problem, your card's fan is probably broken.
█||||()||||█Ξ███████████████████)

Aevar's Avatar


Aevar
12.14.2011 , 09:20 PM | #5
try updating drivers as well. And ya, that anistropic filter and anti-aliasing messes up a lot of games as far as i know. i usually keep it off.

Darth_Malevolent's Avatar


Darth_Malevolent
12.14.2011 , 09:23 PM | #6
Im not computer savvy at all, it says it requires Intel 4100 or better I suppose, where does Intel(R) 4 Series Chipset Family Fall in that category?
The Dark Side is Omnipotent in this one

Darth_Malevolent's Avatar


Darth_Malevolent
12.14.2011 , 09:55 PM | #7
I don't see any of those features your telling me to turn off under preferences
The Dark Side is Omnipotent in this one