Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

FPS issues, suggestions?

Zirhark's Avatar


Zirhark
12.14.2011 , 08:11 PM | #1
Hey there guys, I need help figuring out my fps issues.

In the beta i was running with 25-30 fps if i remember right, with all the settings between medium and high. Now I can't get above 10 or 11 fps with everything on low, with my average fps around 7.


I have an Nvidia GeForce 9400 GT, AMD Phenom 9750 Quad-Core, 4 gigs of ram, and win7 64-bit. With these specs I shouldn't have a problem running the game but its horrible, indoors i get 5 fps outside i get between 7 and 11.

I tried the trick that seems to be working for some people where you turn everything up to high and then shadows off, this didn't effect my fps at all, didn't go up or down. If nothing else, by logic my performance should have gotten worse.

Does anyone have any suggestions?

Ludwig_VanCover's Avatar


Ludwig_VanCover
12.14.2011 , 08:16 PM | #2
I am having the same issues, though this is not correct forum for this topic, and I fear that this post may go unnoticed by the game support team.
░▒ General Ludwig VanCover - The Army of Light ▒░
░▒ "The Time is Always Right to Do What is Right." ▒░
Acting Grandmaster of The Army of Light | Recruiting Tanks, and Healers
Commando Healer Extraordinaire - TEH Server

LouieLazer's Avatar


LouieLazer
12.14.2011 , 08:18 PM | #3
In beta at least for me, I was able to turn down various settings including the grass and tree detail and see noticeable improvement in my fps.

It's worth saying that now I tried the same thing and haven't seen any effect but it's still worth a try I suppose
All we know is...he's called The Stig

Frigidman's Avatar


Frigidman
12.14.2011 , 08:20 PM | #4
Trying checking/unchecking the windowed boxes and exclusive full screen boxes on and off, hitting apply between them. Then set them to "not windowed" and "exclusive on". Hit apply. This ensures they get cleared and set right.

The other thing to try, is going through every graphic setting and manually changing them all to some other value then what they are currently showing. Hit apply, and relaunch the game.

I only mention this, because in a couple of the beta's, the settings shown in prefs, were not actually the settings the game was using! haha. Can't hurt to try?
Hire website designers that actually have had real life experience in the job.
Then let me know so I can return to the forum.

Ludwig_VanCover's Avatar


Ludwig_VanCover
12.14.2011 , 08:24 PM | #5
The game worked excellent during the stress test. I had good FPS. I did keep the Beta launcher, though, which may be the cause of the problem. I am currently installing the OFFICIAL launcher, from swtor.com/download. I also deleted the preference and hidden files for SWTOR, as well. A clean install may be the answer.
░▒ General Ludwig VanCover - The Army of Light ▒░
░▒ "The Time is Always Right to Do What is Right." ▒░
Acting Grandmaster of The Army of Light | Recruiting Tanks, and Healers
Commando Healer Extraordinaire - TEH Server

Sundragon's Avatar


Sundragon
12.14.2011 , 09:18 PM | #6
I copied this suggestion from Bioware before they wiped the forum:

Greetings all,

We are sorry to hear that you are encountering this problem.

We would suggest to try the troubleshooting steps below, in order to solve it:
1. Open Cataclyst/Ati Control Center or Nvidia control panel
2. Set Anisotropic Filtering to 16
3. Optionally, force AA to x2,x4 or x8
4. Set In-Game Anisotropic Filtering to "low".
If the issue persists, we ask that you please try the following:

1 Go to game Preferences / Graphics. Turn off the 'bloom' option from the 'Advanced' section. This should give you about 10-20 fps increase.*

2- This one is for high end PCs. If your game has high fps but is still stuttering, please go to game Preferences / Graphics and turn on the 'vertical sync' option in 'General' section. This should improve your framerate issue (however, this may decrease fps in low end machines though).*

Please let us know if any of these solutions was helpful, and no matter what the result is, please post your Dxdiag file here, if possible.
(Don't forget to use 'spoiler' tags when pasting DxDiag file.)

To find your dxdiag information, please do the following:*
Go to Start menu*
Type dxdiag into the Search/Run box*
Select the "Save All Information" button*
This will create a dxdiag.txt file
█||||()||||█Ξ███████████████████)

imanujakku's Avatar


imanujakku
12.14.2011 , 09:25 PM | #7
in beta i would turn shadows off (crank slider all the way down) on my laptop and fps would go from 30 to 55-60 plus. nothing else seemed to affect frame rate but shadows for me.

Zirhark's Avatar


Zirhark
12.14.2011 , 09:25 PM | #8
Quote: Originally Posted by Ludwig_VanCover View Post
The game worked excellent during the stress test. I had good FPS. I did keep the Beta launcher, though, which may be the cause of the problem. I am currently installing the OFFICIAL launcher, from swtor.com/download. I also deleted the preference and hidden files for SWTOR, as well. A clean install may be the answer.
Please let me know if this works, I would be more than happy to reinstall if it would fix my problem.

Ya I couldn't figure out where to put this topic, customer service shut me down real quick when i posted over there and on the general forum it gets pushed down a few pages in seconds so ya. I tried the reloading thing, no avail.

Its just so weird cuz it worked so great the beta weekend and now its just the worst.

Paralassa's Avatar


Paralassa
12.14.2011 , 09:37 PM | #9
Hi there!

There is an active discussion topic for issues with lag/performance:

Too laggy to move/fight

You may also want to check out these two guides for increasing performance on your computer:

*Ultimate* Desktop PC Performance Guide
Ultimate Guide to speeding up Win 7 on low/mid range systems

In the interest of consolidating discussion, we have closed this thread and ask that you use the one linked above for any further discussion. Thank you!