Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Update and Information Request: Error Code 9000

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Update and Information Request: Error Code 9000
 
First BioWare Post First BioWare Post

ShadowRiderX's Avatar


ShadowRiderX
01.23.2012 , 11:40 AM | #841
My server is Dark Reaper and it is getting progessivly worse i have played the game for weeks with out this problem so i know its nothing on my end it is now preventing me from even being able to move. Once i log in i get disconnected. this is getting redicoulus on the count that i am paying to play a game that i cant play.......

ShadowRiderX's Avatar


ShadowRiderX
01.23.2012 , 11:43 AM | #842
Quote: Originally Posted by OdinsBloods View Post
"First, let me tell you a bit about Error Code 9000 – unfortunately, it’s a pretty generic error. It means that for some reason, the server hasn’t heard from the client for over 30 seconds. That’s why a lot of you are seeing the latency meter go into the red just before the disconnect happens, because the connection isn’t getting information through. However, that means that there can be any number of reasons that the error can show up. It could be something on our end like a flaky router, something on your end like a bad wireless or antivirus, or something in between like an ISP throttling traffic. For all the people posting here, there are probably dozens of different causes, but we do think that there is one issue that is hitting most people, which shows up as repeated disconnects every few minutes with a latency spike just before the disconnect."


So, if it is my issue, which it really sounds like they are implying here, why was I able to play for a month without issue? Why did I not have the error in between December 22, 2011 and January 19, 2012?

I have to believe that something changed on BW end. If I made no changes to my computer, had the error that many of these people are having, saw a window with NO problems between the end of December up until this last patch, how can you even begin to believe that it is my problem?

The only other explination is that something happens once a month to my computer or my provider. Does anyone think that might be the case?

But, what I don't get is that I can play other online games without issue, never getting dissconnected. DCUO, LOL, Starcraft 2 as examples.
Same here this error has only appeard to me very recently and has prohibited me from being able to finaly reach lvl 50 i have been stuck at lvl 48 for about a week now...

Lordauric's Avatar


Lordauric
01.23.2012 , 11:45 AM | #843
I played for hours last night with no issue. Today, however is a completely different story. Playing a trooper on Tatooine, on the Bergeren Colony Server and I cant 5 min before I crap out. Speedtest shows 30mbs down, 3 up. Not my end for sure.

JovethGonzalez's Avatar


JovethGonzalez
01.23.2012 , 12:02 PM | #844 Click here to go to the next staff post in this thread. Next  
Hi everyone! We requested another round of logs from folks and many thanks to those of you that provided them. Our investigation of this issue is well underway and we'd like to ask that, for those of you still experiencing this issue, please see if it persists when you play on the public test server and let us know here in this thread. Thank you!

Randytravis's Avatar


Randytravis
01.23.2012 , 12:24 PM | #845
Quote: Originally Posted by JovethGonzalez View Post
Hi everyone! We requested another round of logs from folks and many thanks to those of you that provided them. Our investigation of this issue is well underway and we'd like to ask that, for those of you still experiencing this issue, please see if it persists when you play on the public test server and let us know here in this thread. Thank you!
I sent a load of tracert's and pathpings by email last night which Steve from the community support team asked me to gather, but i have not heard back yet. I would try the public test server however that involve me downloading 11gb's which would not only take me ages but also i would prob break my download limit for this month

Edit: It's quite possible players may see improved game play on the public test server as the population isn't as large on that server. With my recent tests my connection issues are far worse the busier the server gets.

JediOrderr's Avatar


JediOrderr
01.23.2012 , 12:27 PM | #846
Quote: Originally Posted by JenHarkness View Post
Hi guys! Thank you for helping us in trying to track down these issues. We are actively working on the disconnects, and I wanted to take a minute to update you all on what we’ve been up to, what our plans are for the next steps, and what additional information we’d like to get from you.

First, let me tell you a bit about Error Code 9000 – unfortunately, it’s a pretty generic error. It means that for some reason, the server hasn’t heard from the client for over 30 seconds. That’s why a lot of you are seeing the latency meter go into the red just before the disconnect happens, because the connection isn’t getting information through. However, that means that there can be any number of reasons that the error can show up. It could be something on our end like a flaky router, something on your end like a bad wireless or antivirus, or something in between like an ISP throttling traffic. For all the people posting here, there are probably dozens of different causes, but we do think that there is one issue that is hitting most people, which shows up as repeated disconnects every few minutes with a latency spike just before the disconnect.

Over the last few weeks, we’ve been tweaking some of our network parameters to try to isolate the specific networking errors and also adding a lot of debugging information to our logs. Our goal is to correlate who gets hit by the problems, when they get hit, and what things they have in common. We’ve got another change we’re going to be trying soon (we have to make sure we don’t break things while we’re fixing other things) but we’d also like to get some additional information from you guys. We’ve got a new and much more specific list to fill out, and the last item is particularly important. We’d like to pick a few tech-savvy folks to get contacted by our networking and server engineers and walk through some debugging steps to try to nail down where the issue is happening. If you’re willing to work with us, please let us know on this thread and we’ll contact you to follow up. (CS will have any info that we’ll need).

Believe me, we want to get this resolved and we’re doing everything we can to try to make that happen!

Information we need:

1. Name of the server where you encounter disconnects
2. Day and time of a 1-2 hour block where you disconnected on average more than once every 15 minutes. (remember to tell us timezone!) We’re looking these up in the logs, so the more specific you can be the better!
3. Have you been receiving the disconnects continually? Are they during particular times of the day? Has it been consistent since launch? Do they tend to group up?
4. How reliably can you reproduce the disconnects? 100%? 75%?
5. Are you on a wired or wireless connection? If wireless, what brand and model of router are you using?
6. Do you share the network connection with others? If so, do they play SWTOR, and have they also experienced disconnects? Are their disconnects at the same time as yours?
7. What version of Windows are you running? Are you running 32 or 64 bit?
8. Are you running any antivirus or firewall programs or any other network filtering program?
9. Would you be willing to be contacted by a BioWare developer and work through some debugging steps hands on with us (most likely via phone)? If so, what timezone are you in?

1. EU Frostclaw
2., GTM +2. 17:00-23:00 when i play but it hasn't happened to me in mornings ( rarely play that time).
3.Getting disconnects continually. Lag spikes and disconnects have appeared since last week, never had a single lag or disconnect before. Discovered this while doing Flashpoints
4.100 %
5.Wired connection
6. I have my internet connected to 2 PCs
7.Win7 64bit
8.Symantec Endpoint Protection
9.Yes, i'd like to but in daytime i'm not home so i can't have all the information as i can when i'm home. GTM + 2.
My life is potato, my dreams are potato, I am potato

Sameria's Avatar


Sameria
01.23.2012 , 01:05 PM | #847
Quote: Originally Posted by Randytravis View Post
Edit: It's quite possible players may see improved game play on the public test server as the population isn't as large on that server. With my recent tests my connection issues are far worse the busier the server gets.
I couldn't agree more with this statement. My whole time beta testing, about 3 months or so long, I NEVER once got disconnected. Once early release started, so did the 9000 error.

For the past 3-4 weeks the 9000 errors have gotten better,(Monday-Thursday: I don't remember the last time I was kicked off), but Friday night through Sunday, is when the disconnects happen to me. High lag spike followed by a disconnect.

Spacegun's Avatar


Spacegun
01.23.2012 , 01:19 PM | #848
Just bought a brand new comp for this game. I cant play more than 5 or 10 minutes on any server without getting the error 9000. Ocassionally it will allow me several hours but that is becoming more rare. I have a stable connection. internet and other games work fine. I have made characters on many servers only to find that the server is clearly not the issue at all. The problem persists no matter how i try to play. meanwhile my friends are surpassing me more each day. I JUST WANT TO PLAY!

anvkin's Avatar


anvkin
01.23.2012 , 01:25 PM | #849
1. Name of the server where you encounter disconnects
Maldanore

2. Day and time of a 1-2 hour block where you disconnected on average more than once every 15 minutes. (remember to tell us timezone!) We’re looking these up in the logs, so the more specific you can be the better!
Today (1/23/12) 10:00 12:00 (PST)

3. Have you been receiving the disconnects continually? Are they during particular times of the day? Has it been consistent since launch? Do they tend to group up?
This hadn't been an issue until Sat night and all day Sunday and all day so far as well

4. How reliably can you reproduce the disconnects? 100%? 75%?
95%

5. Are you on a wired or wireless connection? If wireless, what brand and model of router are you using?
Wireless. NetgearWN3000RP

6. Do you share the network connection with others? If so, do they play SWTOR, and have they also experienced disconnects? Are their disconnects at the same time as yours?
Several cpus on the home network as well as a media playing device. No issues with the other connections

7. What version of Windows are you running? Are you running 32 or 64 bit?
7 64bit

8. Are you running any antivirus or firewall programs or any other network filtering program?
Standard Windows firewall, UAC activated

9. Would you be willing to be contacted by a BioWare developer and work through some debugging steps hands on with us (most likely via phone)? If so, what timezone are you in?
Sure PST time zone although I'm a monday to friday drone. So wont be avil till after 6Pm

Vrsixed's Avatar


Vrsixed
01.23.2012 , 01:27 PM | #850
1. Name of the server where you encounter disconnects VenZallow
2. Day and time of a 1-2 hour block where you disconnected on average more than once every 15 minutes. (remember to tell us timezone!) We’re looking these up in the logs, so the more specific you can be the better! 12:00pm-2:00pm kicked once every 10 minutes
3. Have you been receiving the disconnects continually? Are they during particular times of the day? Has it been consistent since launch? Do they tend to group up? Played beta and well into launch with no issues until last week. Now I disconnect all the time.
4. How reliably can you reproduce the disconnects? 100%? 75%? nothing to reproduce, it just happens, no matter where I am.
5. Are you on a wired or wireless connection? If wireless, what brand and model of router are you using? wired
6. Do you share the network connection with others? If so, do they play SWTOR, and have they also experienced disconnects? Are their disconnects at the same time as yours?
yes shared with tv running netflix and multiple wireless devices such as iphone and ipad, no one else playing swtor
7. What version of Windows are you running? Are you running 32 or 64 bit? win xp 32 bit
8. Are you running any antivirus or firewall programs or any other network filtering program? Symantec Endpoint Protection, disabled however
9. Would you be willing to be contacted by a BioWare developer and work through some debugging steps hands on with us (most likely via phone)? If so, what timezone are you in? Yes, daytime is best prior to 3pm EST
You can either work for me or I shoot you in the face.
Spybreaker | Imperial Sniper | Ven Zallow | Gloom Walkers
Spyrunner | Imperial Operative | Ven Zallow |Gloom Walkers