Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Better Performance In Beta

SpiderBorlnad's Avatar


SpiderBorlnad
12.14.2011 , 02:30 PM | #1
I know my laptop is older, but the game ran fine during the beta with all the settings turned down.
Now I can barely move.

From what I can tell, other people are having this problem too. What changed?
Where's the switch on this thing??
I sense much beer in him.

Chiyeko's Avatar


Chiyeko
12.14.2011 , 02:32 PM | #2
Quote: Originally Posted by SpiderBorlnad View Post
I know my laptop is older, but the game ran fine during the beta with all the settings turned down.
Now I can barely move.

From what I can tell, other people are having this problem too. What changed?
same thing I asked here in my topic http://www.swtor.com/community/showthread.php?t=20186

really annoying this I must say.
Inter arma enim silent leges.

Stoshy's Avatar


Stoshy
12.14.2011 , 02:33 PM | #3
Turn off vertical sync?
FIN

Kiny_o's Avatar


Kiny_o
12.14.2011 , 02:34 PM | #4
There are more people playing now?
Pluss it was beta... allot has been added i imagine

Paralassa's Avatar


Paralassa
12.14.2011 , 02:35 PM | #5
Hi there!

While we understand your frustrations, the Customer Service forum is for those having issues with their accounts or accessing the game. There is, however, an active discussion topic for issues with lag:

Too laggy to move/fight

In the interest of consolidating discussion, we have closed this thread and ask that you use the one linked above for any further discussion. Thank you!