Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Cannot See Server List: ERROR 4001

STAR WARS: The Old Republic > English > Customer Service (Read-Only)
Cannot See Server List: ERROR 4001
First BioWare Post First BioWare Post

Proto's Avatar

01.21.2012 , 10:41 AM | #1
Please help with some real resolution on this! God I'm so sick of all the bugs in this game!!!!

Ever since last patch I can't even see a server list now. I have WIN 7 64 Bit, all updated drivers, all service packs installed. Most recent .NET Framework, Java, C++ installs. I even tried totally disabling my firewall, flushing DNS / IP settings. Nothing is working.

Beesodd's Avatar

01.21.2012 , 10:47 AM | #2 Click here to go to the next staff post in this thread. Next  
Greetings Proto,

If you are using a laptop, are you connected wirelessly? If so, have you tried connecting to your router using an ethernet cable, to see if the issue is replicated?

Also, please ensure that the relevant ports are open.

Edit: I can see that you have resolved your issue. I apologize for any inconvenience caused.

Beesodd | BioWare Customer Service - Forum Support| Find help for all EA Games at Answer HQ.

Proto's Avatar

01.21.2012 , 10:53 AM | #3
Guys. I found the solution to this issue as a temporary workaround. Its ridiculous, but clearly whatever they changed last patch has screwed with network code or somehow stepped backwards in how the game is run to change / fix issues others had while introducing new problems like 4001.

All you have to do is this:

Right click the launcher.exe on your desktop
Go to properties
Click the tab called 'Compatibility'
check the box
Make sure Win XP SP3 is in the dropdown
Click OK

See image example:

For whatever reason, this works. I could not see a server list at all until this was done.

Bioware rep: My workaround doesn't really solve the issue. It is just a bandaid for something that is clearly wrong. I suggest you forward this information to the right people so they can see why its working in a compat mode for some users and others on WIN7 64 its no issue.

doolsapien's Avatar

02.19.2012 , 06:42 AM | #4
I have been playing the game fine up until a day ago , now I get a blank server list.
I have included the ports as suggested but still nothing .
I have tried the launcher fix , and also repaired the launcher upon login.
However still no server list .

Any ideas ? Im itching to play but cant access its very frustrating.
Will I be compensated for loss of game time by extension of my online game time ?
"There is no death, there is the Force."

renegadeimp's Avatar

02.19.2012 , 06:46 AM | #5
Do a quick forum search. There are a few workarounds for this issue. The reason it occurs is because your client isnt connecting to the server correctly.
Streamline - A guide to speeding up low - mid range Computer systems.
Latency Thread - Latency issue gathering thread..
Have a tech issue you need help with? You can nomally find me on the Customer Support forum.

doolsapien's Avatar

02.19.2012 , 07:56 AM | #6
Thanks I'll continue to look , hopefully it will just fix itself as it has done before.
I cant find anything in the search ?

I will keep looking thanks
"There is no death, there is the Force."

Ogada's Avatar

02.19.2012 , 08:51 AM | #7 This is the last staff post in this thread.  
Greetings Doolsapien,

If you are still getting this error, please make sure that SWTOR and the launcher are added to the exceptions list for your anti-virus and firewall software.

Thank you for your time.
Ogada | BioWare Customer Service Forum Support

doolsapien's Avatar

02.19.2012 , 02:03 PM | #8
I checked the firewall list and for some reason SWTOR was blocked but the launcher wasnt , very odd , however it works fine now.

Good luck to those still not able to play !
"There is no death, there is the Force."

galek_morex's Avatar

03.09.2014 , 09:16 AM | #9
proto i tried it like you said and it didnt work....hmm i am not a computer guy by no means at all what so ever but i will try and tinker as best i can

galek_morex's Avatar

03.09.2014 , 09:23 AM | #10
i have also done as the assistance guy asked as well and still doesnt work