Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

high "ms" on all servers? (EU)

STAR WARS: The Old Republic > English > Customer Service
high "ms" on all servers? (EU)

SithyJerry's Avatar


SithyJerry
12.14.2011 , 12:48 PM | #1
I've been playing since the 13th (and two beta weekends before that) with 60ms on average.

Since 5pm (gmt+1) all of a sudden its like climbing slowly.. starting from 100ms and now its 350! on average :S

For no apparent reason whatsoever.
I notice most EU servers are on (very)Heavy or full but other people say or claim they have like 43ms.

I checked everything and its not on my side.
No background programs downloading or somesuch.

Am i the only one?

Customer support told me to provde Dxdiag and refresh UI and such bull..nonsense.

It seems to me its the servers but a lil verification from other players would be nice.


Edit : so far i relogged - tried other character (to see if other area is affected aswell) - quit the game several times - went to other server.
Same result for all.

Soon as i enter 350ms or whatever it is at.
Again in my eyes that points to a server problem.
DDE VIP and CE vip (yup 2 accounts w00t)

Dirtylobster's Avatar


Dirtylobster
12.14.2011 , 12:50 PM | #2
I would appreciate a list of actual locations for EU servers since I care more for low latency like you do than to play on a server with a cool name

badTasteee's Avatar


badTasteee
12.14.2011 , 12:52 PM | #3
i'm in the same boat. 150-200ms on all european servers.
None are more hopelessly enslaved than those who falsely believe they are free.
'Johann Wolfgang von Goethe'

SithyJerry's Avatar


SithyJerry
12.14.2011 , 01:01 PM | #4
Damn this disappears fast.

I checked with my ISP its not a problem on their end.


ADD MORE SERVERS.

Its clear you already cant handle the load.
DDE VIP and CE vip (yup 2 accounts w00t)

Kotyy's Avatar


Kotyy
12.14.2011 , 01:06 PM | #5
I disagree on that they cant hold the load, hovever i agree on opening more servers as the EU servers seems to be all populated well.