Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Computer that should be able to run the game but lagging like crazy

STAR WARS: The Old Republic > English > Community Content
Computer that should be able to run the game but lagging like crazy

-Atrain-'s Avatar


-Atrain-
01.13.2012 , 03:59 PM | #1
Hello all,

Thank you in advance for posting, here are my current specs:

Motherboard: ASUS #M4A78T-E (AM3 CPU, DDR3)
Ram: 4Gb x 1 Corsair
CPU: AM3 2.8
Graphics Card: ATI 6770
OS: Window 7 64bit

Just did a clean install but I still get lag mostly in the form of "shuddering". the kicker is the fact that no mater if I have my setting on Max or on as low as possible the game runs the same. I can be anywhere from the imperial fleet, a flash point or a battleground and the effect is the same. as a side note my wifes pc has a 2.5 amd, 2gbx2 ddr2 80mhz and a nvidea 550 TI and runs the game perfect. the only difference I can see is the brand on graphics card and the fact she has 2 cards of ram vs 1.

Thanks again all

Remair's Avatar


Remair
01.13.2012 , 04:02 PM | #2
The RAM is kinda on the low side. Windows 7 uses about 2-3 Gb in idle processes. That doesn't leave much for swtor to use. Also is your processor at least dual core?

That's all I can notice.

-Atrain-'s Avatar


-Atrain-
01.13.2012 , 04:12 PM | #3
Yes, its a Quad core AMD 2.8. I can "core unlock" to overclock the CPU but the last time I did that the system was very unstable crashing a lot.

Thanks, Atrain

AwesumPossum's Avatar


AwesumPossum
01.13.2012 , 04:13 PM | #4
Might be your video card? is it just SWTOR?
Dooka (Scoundrel - The Twin Spears - Main) | Aki (Sniper - The Twin Spears)
Triumvirate Guild (PVP)
Twitter | My Stream

warrenTU's Avatar


warrenTU
01.13.2012 , 04:15 PM | #5
Quote: Originally Posted by Remair View Post
The RAM is kinda on the low side. Windows 7 uses about 2-3 Gb in idle processes. That doesn't leave much for swtor to use. Also is your processor at least dual core?

That's all I can notice.
If yours is using that much RAM on idle you have allot going on in the background, mine uses 1 GB at most. Might want to run a Malware scan.

-Atrain-'s Avatar


-Atrain-
01.13.2012 , 04:18 PM | #6
Yes its just for starwars, the card is brand new. also I just wiped the hard drive and it runs the same as before.

-Atrain-'s Avatar


-Atrain-
01.13.2012 , 04:20 PM | #7
Quote: Originally Posted by AwesumPossum View Post
Might be your video card? is it just SWTOR?
the radeon HD 6770 was rated better than the Nvidea 550TI that my wife uses and she runs it perfect.

AwesumPossum's Avatar


AwesumPossum
01.13.2012 , 04:22 PM | #8
Quote: Originally Posted by -Atrain- View Post
the radeon HD 6770 was rated better than the Nvidea 550TI that my wife uses and she runs it perfect.
I was just suggesting if it was happening in other games, you may have to RMA the card. Their like cars sometimes you get lemons.

You might also want to give your RAM a diagnostic. Which takes 8+ hours just to check if any of your RAM sticks have a error.
Dooka (Scoundrel - The Twin Spears - Main) | Aki (Sniper - The Twin Spears)
Triumvirate Guild (PVP)
Twitter | My Stream

-Atrain-'s Avatar


-Atrain-
01.13.2012 , 04:27 PM | #9
Quote: Originally Posted by AwesumPossum View Post
I was just suggesting if it was happening in other games, you may have to RMA the card. Their like cars sometimes you get lemons.

You might also want to give your RAM a diagnostic. Which takes 8+ hours just to check if any of your RAM sticks have a error.
Ill run a ram check, didnt think of that. all I know is this is driving me nuts lol. also like a car, the darn thing is making a noise and I can hear where its coming from but no mater how many new parts are put in it, it almost seems to gets worse. lol

AwesumPossum's Avatar


AwesumPossum
01.13.2012 , 04:41 PM | #10
Quote: Originally Posted by -Atrain- View Post
Ill run a ram check, didnt think of that. all I know is this is driving me nuts lol. also like a car, the darn thing is making a noise and I can hear where its coming from but no mater how many new parts are put in it, it almost seems to gets worse. lol
lol uh oh. Maybe it is over heating or a fan is hitting something. Might be your Video Card fan those things can be noisy depending on which one.

My money is on the video card but you never know until you try everything. Computers can be frustrating.

I used have a problem with my ATI cards all the time and switched to nVidia and haven't had a problem since *knock on wood*. I even got 2 dud cards which is extremely annoying.

Good luck on your journey lol. Hope it works out for ya and you don't end up throwing it through a window.
Dooka (Scoundrel - The Twin Spears - Main) | Aki (Sniper - The Twin Spears)
Triumvirate Guild (PVP)
Twitter | My Stream