Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Trooper - Full Auto

Sunsoar's Avatar


Sunsoar
12.13.2011 , 09:21 PM | #1
Channeled ability for 3seconds that does X amount of damage every second. It STILL only ticks for two damage, and the health bar of your target only goes down twice. The damage that ticks is consistent with what shows in Full Auto tool tip.
Without me, it's just aweso.
i7 950 @ 4.0ghz, ASUS X58 Saber mobo, 12gb RAM@1866mhz, 6970 LIGHTNING, 120GB SSD, 1TB HDD, BWU Keyboard, Razer Mamba, PC350s, XFX XXX 750w PSU.
This game desperately needs some sandbox elements. Repetitive grinding is not fun.

Mal-Sharran's Avatar


Mal-Sharran
12.13.2011 , 09:23 PM | #2
I've noticed this as well, hopefully they address this. Love the ability, but until it's fixed I don't even end up using it in favor of other options.
I'd say 'IMHO', but it would be a lie. I'm not humble, and everything I say is stone cold fact.

Axaeron's Avatar


Axaeron
12.13.2011 , 09:49 PM | #3
If you use it while being hit by an enemy NPC, you're likely suffering pushback that gets rid of the last tick. The way it's designed, it applies damage at 1s, 2s, and 3s. So the only way to get the last tick at 3s (100% of the 3s channel) is to get the entire channel off without being hit.

I experienced the same thing in the beta, but I chalked it up to the group of enemies shooting me. I could be wrong though!

Try shooting a melee mob from ranged and see if all 3 ticks occur before he damages you.

Cheers!

Gydion's Avatar


Gydion
12.13.2011 , 10:26 PM | #4
Tonight I thought I was getting the full 3 seconds of damage most of the time. Perhaps being hit does cause you to lose some of that damage. I'll try to pay more attention to it.

Sunsoar's Avatar


Sunsoar
12.13.2011 , 10:44 PM | #5
Weak and standard mobs are stunned for the duration of this effect, so I am not getting hit when I test it, with one mob alive out of a group. No, they're not dying before the channel is up.

I will test it more tomorrow on a player character and see, but I have been noticing that it only ticks twice for quite a while now. Even through beta.
Without me, it's just aweso.
i7 950 @ 4.0ghz, ASUS X58 Saber mobo, 12gb RAM@1866mhz, 6970 LIGHTNING, 120GB SSD, 1TB HDD, BWU Keyboard, Razer Mamba, PC350s, XFX XXX 750w PSU.
This game desperately needs some sandbox elements. Repetitive grinding is not fun.

RuinedNub's Avatar


RuinedNub
12.14.2011 , 12:40 AM | #6
It's not working properly. Ran with some guildies and my fellow trooper along with myself were only getting two ticks of damage with full auto. That's taking no aggro, etc.