Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer
×

Really bad FPS with a high end PC.

STAR WARS: The Old Republic > English > Customer Service
Really bad FPS with a high end PC.

BEViking's Avatar


BEViking
01.04.2012 , 10:56 AM | #11
Quote: Originally Posted by Oldmanwinter View Post
This is very strange.

My computer is certainly not meant for gaming by any means and it runs pretty smooth.

What areas specifically are you experiencing the low FPS rate? Also, what's your internet connection lookin' like?

I run everything with the lowest settings, including tree details. Shadows turned off etc. I noticed if you slightly reduce the resolution it greatly helps the FPS.
100/100 Mbit/s. So it shouldn't be due to a bad connection.

It's mostly indoors. I just noticed that my graphic cards are just running at 5% or less when im inside a city.
I have 110 FPS everywhere outdoors, but as soon as units appear the FPS plummets.
The more units, the worse FPS i get.
Imperial fleet at the moment and i've got a whopping 8 FPS with 20 people on the screen.

MrSchmo's Avatar


MrSchmo
01.04.2012 , 10:56 AM | #12
Ha, I wish I had 40 fps during fights. I top out at 30 if I'm lucky. Then dip to 10-20 in hight traffic and battles. I don't have super comp like the op, but if I can play every other game at max, why can't this one. I refuse to upgrade my system when I exceed all the requirements.

It playable for now, but I can't imagine what a high lvl raid would be like. Need a fix fast.
That's why they call it space, cause there is so much of it.

Paul_E_Ester's Avatar


Paul_E_Ester
01.04.2012 , 10:58 AM | #13
try diableing hyper-threading, see if that works

pocketthesaurus's Avatar


pocketthesaurus
01.04.2012 , 11:01 AM | #14
Quote: Originally Posted by BEViking View Post
Intel core i7 3930K (6 cores)
32 GB ram
Double GTX 580 cards in SLI
SSD harddrive
And a PSU powerful enough to make use of the stuff.

The max fps i get in game is 110 but it can drop down below 20 in cities.
In most fights i don't even have 40 FPS.
Running the newest drivers for the GFX, motherboard, hard drive controller etc.

1920x1080 and everything on max.
Doesn't matter if i play on 1280 x 1024 with everything on low, i still get fpsdrops.

Reinstalled the drivers, tried older versions of the gfx drivers.
Turned off SLI, put the game in fullscreen and windowed.
Doesn't really change stuff.


How can i make the game playable?
I would try to force v-sync if I were you.

BEViking's Avatar


BEViking
01.04.2012 , 11:16 AM | #15
Quote: Originally Posted by Paul_E_Ester View Post
try diableing hyper-threading, see if that works
Havn't tried that. But doesn't that just remove micro stuttering if present?


Quote: Originally Posted by pocketthesaurus View Post
I would try to force v-sync if I were you.
Turned it on. Seems to have improved, i don't drop below 60 now. But i havn't been to any cities yet.
Thank you for the tip!

Paul_E_Ester's Avatar


Paul_E_Ester
01.04.2012 , 11:26 AM | #16
Quote: Originally Posted by BEViking View Post
Havn't tried that. But doesn't that just remove micro stuttering if present?


Posible, but its worth a shot, my old tech Intel q9650 quad doesnt have Hyper-threading and the game works without a hitch.

Zergor's Avatar


Zergor
01.04.2012 , 12:26 PM | #17
I would look at this thread that should be stickied if its not already. This made a huge difference on my rig. Specifically XP compatibility mode sp3 for Launcher and Swtor.
http://www.swtor.com/community/showthread.php?t=114264

Alkiii's Avatar


Alkiii
01.04.2012 , 12:29 PM | #18
Quote: Originally Posted by BEViking View Post
Intel core i7 3930K (6 cores)
32 GB ram
Double GTX 580 cards in SLI
SSD harddrive
And a PSU powerful enough to make use of the stuff.

The max fps i get in game is 110 but it can drop down below 20 in cities.
In most fights i don't even have 40 FPS.
Running the newest drivers for the GFX, motherboard, hard drive controller etc.

1920x1080 and everything on max.
Doesn't matter if i play on 1280 x 1024 with everything on low, i still get fpsdrops.

Reinstalled the drivers, tried older versions of the gfx drivers.
Turned off SLI, put the game in fullscreen and windowed.
Doesn't really change stuff.


How can i make the game playable?
Either you have something seriously wrong going on with your setup or you're trolling. I'm sorry, but I'm going with the latter on this one.
“When I die, I want to go peacefully like my Grandfather did, in his sleep ... not screaming like the passengers in his car.”

BEViking's Avatar


BEViking
01.04.2012 , 12:46 PM | #19
Quote: Originally Posted by Alkiii View Post
Either you have something seriously wrong going on with your setup or you're trolling. I'm sorry, but I'm going with the latter on this one.
Computer specc http://i.imgur.com/TjBDa.png
FPS in lower left corner http://i.imgur.com/QX1ga.png

And that FPS is on a good day. Usually got worse when roaming "crowded" areas.
So please, refrain from calling me a troll, i'd be much happier if you could provide me with an idea on how to fix this problem.

Alkiii's Avatar


Alkiii
01.04.2012 , 02:06 PM | #20
Quote: Originally Posted by BEViking View Post
Computer specc http://i.imgur.com/TjBDa.png
FPS in lower left corner http://i.imgur.com/QX1ga.png

And that FPS is on a good day. Usually got worse when roaming "crowded" areas.
So please, refrain from calling me a troll, i'd be much happier if you could provide me with an idea on how to fix this problem.

Try this.

Right click on the SWTOR icon on your desktop or in Start Menu program files, select Properties. In the window that appears select the Compatibility tab. Under Compatibility Mode check Run this program in compatibility mode for: From the box below select Windows XP (Service Pack 3) and then click OK.

Click Disable Visual Themes.
Click Disable Desktop Composition.
Click Run as Administrator.


Please let us know if this helps. It helped my SLI 580 GTX's cool down and gave me a nice little 20-35 FPS boost.
“When I die, I want to go peacefully like my Grandfather did, in his sleep ... not screaming like the passengers in his car.”