Please upgrade your browser for the best possible experience.

Chrome Firefox Internet Explorer

Cant play? Black screen

First BioWare Post First BioWare Post

lilstevo's Avatar

01.03.2012 , 04:44 PM | #1
I open the launcher,click play, and it quickly goes to a black screen and then back to my desktop.
I have:
1. Repaired 3 times
2. Fixed launcher
3. Changed the .ini file
basically everything i can find and still havent been able to play the game.

Is there anything else that could get it to work?

Ive contacted support and still no reply.

LohKey's Avatar

01.03.2012 , 05:12 PM | #2
I would start by making sure you meet the minimum specs for your system. Than update all your graphic drivers, if that doesn't work make a new user account on your computer and try it from there so it's running clean. If that doesn't work I have no idea what to tell ya
Pawning your Jedi Like A *** *** girl scout ***** *** ******* in your moms ****** *****!!
BH since 2004!

MegaActionHero's Avatar

01.03.2012 , 09:43 PM | #3
Same exact issue here. Just downloaded the game yesterday and have yet to seen any graphics. I click play, hear sound and intro music/voice ext. Mouseclicks get response sounds. Just no pictures at all.

Going to ask for my money back soon.

GeorgieSWTOR's Avatar

01.03.2012 , 09:52 PM | #4
Same thing happening to me... You guys find any solutions?

Cerimon's Avatar

01.03.2012 , 10:29 PM | #5 This is the last staff post in this thread.  
Greetings All,

Please see this post for troubleshooting steps when the game crashes after pressing play. Also take a look at our Launcher Troubleshooting Guide for additional steps to try.

We apologize for any inconvenience caused and Thank You for playing Star Wars™: The Old Republic™

Cerimon | BioWare Customer Service - Forum Support

MegaActionHero's Avatar

01.04.2012 , 11:01 AM | #6
I found if you got to the ATI Catalyst Control Center website there was a new program released on 12.13.11 which I downloaded and installed. After that the game worked fine. Though I did just get an error 9000 a few minutes ago.