View Single Post

WayneInAustin's Avatar


WayneInAustin
02.08.2012 , 02:52 PM | #1
Edited: Never mind - This is actually a bug. The problem is that the item to click on is NOT VISIBLE, but is nevertheless there. The item is not on top of the tower but on the ground on a rock or piece of ruin, just like the other quest items... only on my screen it was not visible...but the mouse icon changed when I moused over the rock, so I was able to complete.

I think this is probably a case where I'm just blind and missing something obvious, but I'm stuck on the quest "Geroya be Haran: Capture Jicoln's Oath to Clan Ordo". The quest symbol (green triangle) seems to indicate the item is inside (or on top of?) a large round toppled tower next to the medical center. I've been all around the tower and could not find any way into it. There is one spot where there are some rectangular holes that seem to lead in, but they are just high enough that I can not jump into them. Tried for about 10-15 minutes at all angles. I even tried going into the hospital to see if there was some way to jump over, but not there or I missed it.
Am I making this way more difficult than it is?
Any info appreciated.
WayneInAustin