View Single Post

PiiTarr's Avatar


PiiTarr
01.21.2019 , 02:21 PM | #4
Quote: Originally Posted by KissTheKiller View Post
I've abandoned it multiple times and reset my flashpoints. I checked under the activities window and it's not available. And I've already reset the story quest and redid the battle for ilum, still same result. Nothing worked. I don't know if it's because my character is level 49? I really only did the class story quest and stealthed through mobs lol but on the wiki it says the flashpoint is for levels 48-50 so I don't know why it's putting me in veteran mode. Thanks for trying to help though.
Every time I've encountered this issue with one of my characters it's been due to them being "underleveled" for story mode. The wiki may be out of date, so I suspect once you ding 50 you'll be able to pick up the FP in story mode. With Prelude to Revan/Forged Alliances you can pick up the overall story mission at something like level 53, but you can't actually get the story mode FPs until 55. These numbers weren't always the case, so there is some older information out there that you may encounter that will now be out of date and somewhat misleading as a result.